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Preliminary Operations 
 

Step 0.  Preparing a Model for Data Processing  
Using the OMS “ProImage” Program 
 
1. Apply contrast marker points on the model surface. 

The number and position of these markers should 
describe  the peculiarities of the Model Geometry. 
The total number of markers should be about 15..25, 
and applying them on the periphery and extreme 
points of the model is most effective.  

Figure 1 

 
 
2. Measure the 3D coordinates of these markers, and 

write them into a file (in our case, MARK_UP.APM).  

Note. The file is a list of marker coordinates in 
ASCII format.  

 
3. Prepare a bitmap with the model image.  
 
4. After starting ProImage open an existing bitmap 

SENS_OFF.B16 that is located in subfolder 
SAMPLES\STEP_0 of the current folder: 

Choose the Open... command from the File menu, 

or 

Click the following icon from the upper 
toolbar: 

Figure 2 
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The standard Open Dialog will appear on your screen. 

Figure 3 

 
 
5. Choose the file STEP_0.B16, and click the Open 

control button. The Open Dialog will be closed, and the 
bitmap will appear on your screen. 

Figure 4 

 
 
6. Select 2D markers on the bitmap in the order of 

sequence of the 3D marker numbers using the model 
photo (Figure 1). 

Choose the Mark... command from the Markers menu, 

or 

Click the following icon from the upper toolbar: 
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Figure 5 

 
The Mark Options Dialog will appear on your screen. 

Figure 6 

 
 
7. Choose all of the needed parameters in the Mark Options 

Dialog as shown above.  
 
8. Click the OK control button. The cursor shape is 

changed to . Click on the points on the bitmap, 
and the markers will be placed at these points. 

Note. The selection of markers is to be performed 
with the highest accuracy. If a marker has been 
selected inaccurately, it is recommended that this 
be corrected through the use of Move radio button. 
Use of the Delete radio button does not change the 
numbers of the rest of the markers. If a marker is 
to be added (using Add radio button), it will 
acquire a number that is equal to the last marker 
number plus one. Therefore, the order of the marker 
numeration may be violated.  
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Figure 7 

 
 
9. To turn off the regime of marker selection, choose 

the Mark... command from the Markers menu again.  
 

10. The quality of the marker choice can be controlled 
using the resection procedure. Choose the Resection... 
command from the OMS Project menu. The Resection Methods 
Dialog will appear on your screen. 

Figure 8 

 
 

11. Choose all of the needed parameters in the Resection 
Methods Dialog as shown above.  

 
12. Click the Project control button. The Mesh Files tab of 

the OMS Property Sheet Dialog will appear on your screen. 
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Figure 9 

 
 
13. Choose all of the needed parameters in the Mesh Files 

tab as shown above. The appropriate files are to be 
chosen from the same folder (subfolder 
SAMPLES\STEP_0 of the current folder). You may type 
the names or click the … control button. In this 
case the standard Open Dialog will appear on your 
screen to permit you to choose the files and their 
storage. 

 
14. Click the OK control button. The Resection Methods Dialog 

will appear on your screen again. 
 
15. Click the OK control button. The warning message 

concerning the absence of the file with the standard 
markers will appear on the screen.  

 
16. Click the OK control button. The warning messages 

concerning the transformation error will appear on 
the screen. 

 
17. Click the OK control button or press Enter. The 

standard Save As Dialog will appear on your screen. 
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Figure 10 

 
 

18. Click the OK control button. The 3D Flowfield will 
be saved on the disk with the default name UP.XYZ in 
the same folder. To visualize it is necessary to 
open this file using the ProField application. 

Note. If the result of the procedure is 
unsatisfactory (the Flowfield is displaced relative 
to the Geometry), it is necessary to repeat Steps 
6-18. 

Figure 11 

 
19. To save the chosen markers on the disk, choose the 

Save Markers As... command from the Markers menu. The 
standard Save As Dialog will appear on your screen.  
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Figure 12 

 
 

20. Choose all of the needed parameters in the Save As 
Dialog as shown above.  

 
21. Click the OK control button. The markers will be 

saved on the disk as the file HST_315DD.MPT. In 
subsequent processing this file will be used as a 
file with standard markers.  
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Chapter 1. Working with a Project File  
 

Step 1. Creating a Project File 
 
1. To create a new project file, choose the New OMS 

Project... command from the OMS Project menu. The OMS Property 
Sheet Dialog will appear on your screen. 

Figure 1.1 

 
 
2. Choose all of the needed parameters in the Test Features 

tab as shown above.  
 
3. Click the Write... control button. The standard Save As 

Dialog will appear on your screen. 
 
4. Enter subfolder SAMPLES\STEP_1 of the current 

folder. 
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5. Type “STEP_1” in the File name text box, and click the 
Save control button. The Save As Dialog will be closed, 
and the project file with the name STEP_1.IMS will 
be created. Its name will appear in the This File 
information pane.  

 
6. Click the Refe Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 

Figure 1.2 

 
 
7. Choose all of the needed parameters in the Refe Files 

tab as shown above.  
 
8. Click the Sens Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 
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Figure 1.3 

 
 
9. Choose all of the needed parameters in the Sens Files 

tab as shown above.  
 

10. Click the Mesh Files tab in the OMS Property Sheet Dialog. It 
will appear on your screen. 
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Figure 1.4 

 
 

11. Choose all of the needed parameters in the Mesh Files 
tab as shown above.  

 
12. Click the Test Features tab in the OMS Property Sheet Dialog. 

It will appear on your screen again. 
 

13. Click the Check control button. The presence of all 
chosen files in the project folder SAMPLES\STEP_1 
will be verified.  

 
14. Click the OK control button. The project file will 

be created, and all chosen parameters will be saved 
into it.  
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Chapter 2.  Processing a Project 
 

Files Necessary for Working with a Project 
 
Subfolder SAMPLES\STEP_2 of the current folder contains 
the following bitmaps: 

1) REFE_DARK.B16 – a dark reference bitmap;  

2) SENS_DARK.B16 – a dark sensitive bitmap; 

3) REFE_OFF.B16 – a wind-off reference bitmap;  

4) SENS_OFF.B16 – a wind-off sensitive bitmap; 

5) REFE_ON.B16 – a wind-on reference bitmap;  

6) SENS_ON.B16 – a wind-on sensitive bitmap. 
 
The following files with information concerning markers 
should be in the same subfolder: 

1) HST_315DD.MPT – markers on the image. This file is 
created manually by the user. It will be used for 3D 
transformations; 

2) MARK_UP.APM – real 3D coordinates of markers on the 
model. 

 
The following files with additional information should 
be in the same subfolder: 

1) STEP_2.IMS – project file that contains the 
information that is necessary for processing the PSP 
test data;  

2) UP.APT – Geometry of the model; 

3) COEFFNEW.CLB – file that contains the coefficients 
of the calibration; 

4) PCO_CAMERA.CAM – file that contains the camera 
parameters. 

 
Step 2. Processing a Project Using Default Parameters 

 
1. After running ProImage open an existing file 

STEP_2.IMS that is located in subfolder 
SAMPLES\STEP_2 of the current folder. Choose the 
Open Project... command from the B Convert menu. The 
standard Open Dialog will appear on your screen. 
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Figure 2.1 

 
 
2. Choose the file STEP_2.IMS, and click the Open 

control button. The Open Dialog will be closed, and the 
wind-on sensitive bitmap will appear on your screen. 

Figure 2.2 

 
 
3. Choose the Dark Frame Subtraction command from the B Convert 

menu to subtract dark bitmaps from the processed 
bitmaps. The corrected wind-on sensitive bitmap will 
appear on your screen. (Four bitmaps--wind-off 
reference, wind-on reference, wind-off sensitive, 
and wind-on sensitive--will be corrected. Use the 
Image command from the View menu to switch between 
these bitmaps.) 
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Figure 2.3 

 
 
4. Choose the Flat Field Correction command from the B Convert 

menu to compensate for vignette-effect of the 
videocamera objective lens and the spread of the 
sensitivity of the photodetector array. The 
corrected wind-on sensitive bitmap will appear on 
your screen. (Four bitmaps-–wind-off reference, 
wind-on reference, wind-off sensitive, and wind-on 
sensitive--will be corrected. Use the Image command 
from the View menu to switch between these bitmaps.) 
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Figure 2.4 

 
 
5. Choose the Automatic Marking... command from the B Convert 

menu. The Quick Marker Search Dialog will appear on your 
screen. 
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Figure 2.5 

 
 
6. Choose all of the needed parameters in the Quick Marker 

Search Dialog as shown above.  
 
7. Click the OK control button. Four bitmaps with 

markers will be created (wind-off reference, wind-on 
reference, wind-off sensitive, and wind-on 
sensitive). Use the Image command from the View menu 
to switch between these bitmaps. 
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Figure 2.6 

 
 
8. Choose the Markers Precise Position... command from the 

B Convert menu. The Revise Markers Dialog will appear on your 
screen. 

Figure 2.7 

 
 
9. Choose all of the needed parameters in the Revise 

Markers Dialog as shown above.  
 

10. Click the OK control button. The position of the 
markers will be corrected. 
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Figure 2.8 

 
 

11. Choose the Hide Markers command from the Markers menu. 
The special symbols of the markers and their numbers 
will become invisible. 

Figure 2.9 

 
 

12. Choose the Fill Up All Markers... command from the B Convert 
menu to remove the marker images from the bitmaps. 
The Fill Up Markers Dialog will appear on your screen. 
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Figure 2.10 

 
 

13. Choose all of the needed parameters in the Fill Up 
Markers Dialog as shown above.  

 
14. Click the OK control button. The position of the 

markers will be corrected. 

Figure 2.11 

 
 

15. Choose the Filtering... command from the B Convert menu to 
apply the 2D Gauss filter on the bitmaps. The Gaussian 
Filter Parameters Dialog will appear on your screen. 

Figure 2.12 

 
 

16. Choose all of the needed parameters in the Gaussian 
Filter Parameters Dialog as shown above.  

 
17. Click the OK control button.  
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Figure 2.13 

 
 
18.Choose the BackGround Work... command from the B Convert 

menu to remove the background on the bitmaps. The 
BackGround Select/Compensate Dialog will appear on your 
screen. 
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Figure 2.14 

 
 

19. Choose all of the needed parameters in the BackGround 
Select/Compensate Dialog as shown above.  

 
20. Click the OK control button. The bitmaps will be 

corrected. 
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Figure 2.15 

 
 

21. Choose the Distortion Correction command from the B Convert 
menu to compensate for objective-lens distortions of 
the bitmaps. This command may be used only once. 
Then it becomes inactive. 

Figure 2.16 

 
 

22. Choose the Alignment Images... command from the B Convert 
menu to align the bitmaps. The Image Alignment Dialog will 
appear on your screen. 
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Figure 2.17 

 
 

23. Choose all of the needed parameters in the Image 
Alignment Dialog as shown above.  

 
24. Click the OK control button. Warning messages about 

the transformation error will appear on the screen.  
 

25. Click the OK control button, or press Enter. Four 
aligned bitmaps will be created (wind-off reference, 
wind-on reference, wind-off sensitive, and wind-on 
sensitive). Use the Image command from the View menu 
to switch between these bitmaps. 
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Figure 2.18 

 
 

26. Choose the Image Convert command from the B Convert menu 
to transform the intensity on the aligned bitmaps to 
the physical parameters. Four bitmaps will be 
created (ratio of the intensity on the reference 
bitmap to the intensity on the sensitive bitmap, 
pressure, ratio of the pressure to the static 
pressure, and Cp). Use the Image command from the View 
menu to switch between these bitmaps. The Cp 
flowfield is shown below. 

Figure 2.19 
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27. Choose the Final Filtering... command from the B Convert menu 

to apply the 2D Gauss filter on the bitmaps with 
physical parameters. The Gaussian Filter Parameters Dialog 
will appear on your screen. 

Figure 2.20 

 
 

28. Choose all of the needed parameters in the Gaussian 
Filter Parameters Dialog as shown above.  

 
29. Click the OK control button. The corrected bitmap 

with the Cp flowfield will appear on your screen. 

Figure 2.21 

 
 

30. Choose the Resection... command from the B Convert menu to 
map the 2D bitmaps (with physical parameters) on the 
3D mesh that describes the model surface. The 
Resection Methods Dialog will appear on your screen. 
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Figure 2.22 

 
 

31. Choose all of the needed parameters in the Resection 
Methods Dialog as shown above.  

 
32. Click the OK control button. The Image Alignment Dialog 

will appear on your screen. 

Figure 2.23 

 
 

33. Choose all of the needed parameters in the Image 
Alignment Dialog as shown above.  

 
34. Click the OK control button. The warning messages 

concerning the transformation error will appear on 
the screen.  

 
35. Click the OK control button, or press Enter. The 3D 

flowfields will be created. For visualization it is 
necessary to open the file STEP_2.XYZ (it is created 
at Step 36) using the ProField application. 
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Figure 2.24 

 
 

36. Choose the Save Results command from the B Convert menu to 
save the active project and the results of the data 
processing. Four bitmaps will be written on the disk 
(STEP_2_P_TO_PST.IMP, STEP_2_IREFE_ISENS.IMP, 
STEP_2_PRESSURE.IMP, and STEP_2_CP.IMP). These files 
contain the bitmaps of the physical parameters and 
the markers on them. Also the file with 3D 
flowfields will be written on the disk (STEP_2.XYZ).  

 
37. Choose the Close Project command from the B Convert menu 

to close the project file.  
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Step 3. Processing a Project Automatically 
 
Subfolder SAMPLES\STEP_3 of the current folder contains 
all of the files necessary to process the project (for 
additional information see Step 2). 
 
1. Open an existing file STEP_3.IMS that is located in 

subfolder SAMPLES\STEP_3 of the current folder (for 
additional information see Steps 1-2 of Step 2.) The 
wind-on sensitive bitmap will appear on your screen. 

Figure 3.1 

 
 
2. Choose the Automatic Convert... command from the B Convert 

menu. The Automatic Convert Scenario Dialog will appear on 
your screen. 
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Figure 3.2 

 
 
3. Choose all of the needed parameters in the Automatic 

Convert Scenario Dialog as shown above.  
 
4. Click the OK control button. Steps 3-35 of Step 2 

will be performed. Default parameters will be used 
in the Dialogs. To change them you may click the 
necessary control buttons, and the appropriate 
Dialog will appear on your screen. 

Four bitmaps will be created (ratio of the intensity 
on the reference bitmap to the intensity on the 
sensitive bitmap, pressure, ratio of the pressure to 
the static pressure, and Cp). Use the Image command 
from the View menu to switch between these bitmaps. 
Also 3D flowfields will be created. 

The Cp flowfield is shown below. 
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Figure 3.3 

 
 
5. Choose the Save Results command from the B Convert menu to 

save the active project and the results of the data 
processing. Four bitmaps will be written on the disk 
(STEP_3_P_TO_PST.IMP, STEP_3_IREFE_ISENS.IMP, 
STEP_3_PRESSURE.IMP, and STEP_3_CP.IMP). These files 
contain the bitmaps of the physical parameters and 
the markers on them. Also the file with 3D 
flowfields will be written on the disk (STEP_3.XYZ). 
For visualization it is necessary to open the file 
STEP_3.XYZ using the ProField application. 
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Figure 3.4 

 
 
6. Choose the Close Project command from the B Convert menu 

to close the project file.  
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Step 4. Processing a List of Projects Automatically 
 
Subfolder SAMPLES\STEP_3 of the current folder contains 
all of the files necessary to process the project (for 
additional information see Step 2). The project files 
from subfolders SAMPLES\STEP_1, SAMPLES\STEP_2, and 
SAMPLES\STEP_3 will be processed. 
 
1. Choose the Automatic Convert List... command from the B Convert 

menu. The Automatic Convert Scenario Dialog will appear on 
your screen. 

Figure 4.1 

 
 
2. Select the STEP_1.IMS file in the Files/Directory list 

using the mouse. 
 
3. Click the > control button. This file will be placed 

in the Files list pane. 
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Figure 4.2 

 
 
4. Double click the [..] in the Files/Directory list. The list 

of folders in the SAMPLES folder will appear on your 
screen. 

Figure 4.3 

 
 
5. Repeat Steps 2-4 to select the STEP_2.IMS file from 

the SAMPLES\STEP_2 folder and the STEP_3.IMS file 
from the SAMPLES\STEP_3 folder.  

Figure 4.4 
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6. Click the OK control button. Three project files 
will be processed automatically. Steps 3-35 of 
Step 2 will be performed. Default parameters will be 
used in the Dialogs. To change these you may click 
the necessary control buttons, and the appropriate 
Dialog will appear on your screen. 

Four bitmaps for each project file will be created 
(ratio of the intensity on the reference bitmap to 
the intensity on the sensitive bitmap, pressure, 
ratio of the pressure to the static pressure, and 
Cp). They will be written on the disk into the 
appropriate folder. These files contain the bitmaps 
of the physical parameters and the markers on them. 

Also 3D flowfields for each project file will be 
created. These files with 3D flowfields will be 
written on the disk into the appropriate folder. 
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Step 5. Influence of Dialog Parameters  
on the Results of Project Processing  
 
Subfolder SAMPLES\STEP_5 of the current folder contains 
the same files as SAMPLES\STEP_2, except that it 
contains a file for the Flat Field Correction and the 
following files with markers on the bitmaps:  

1) REFE_OFF.MPT – markers on the wind-off reference 
bitmap;  

2) SENS_OFF.MPT – markers on the wind-off sensitive 
bitmap; 

3) REFE_ON.MPT – markers on the wind-on reference 
bitmap;  

4) SENS_ON.MPT – markers on the wind-on sensitive 
bitmap. 

 
 
1. Open an existing file STEP_5.IMS that is located in 

subfolder SAMPLES\STEP_5 of the current folder (for 
additional information see Steps 1-2 of Step 2). The 
wind-on sensitive bitmap will appear on your screen. 

Figure 5.1 

 
 
2. Choose the Dark Frame Subtraction command from the B Convert 

menu to subtract the dark bitmaps from the processed 
bitmaps. The corrected wind-on sensitive bitmap will 
appear on your screen. (Four bitmaps-–wind-off 
reference, wind-on reference, wind-off sensitive, 
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and wind-on sensitive--will be corrected. Use the 
Image command from the View menu to switch between 
these bitmaps.) 

Figure 5.2 

 
 
3. Choose the Flat Field Correction command from the B Convert 

menu to compensate for distortions of the 
videocamera objective lens and the spread of the 
sensitivity of the photodetector array. The 
corrected wind-on sensitive bitmap will appear on 
your screen. (Four bitmaps-–wind-off reference, 
wind-on reference, wind-off sensitive, and wind-on 
sensitive--will be corrected. Use the Image command 
from the View menu to switch between these bitmaps.) 
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Figure 5.3 

 
 
4. Choose the Automatic Marking... command from the B Convert 

menu. The Quick Marker Search Dialog will appear on your 
screen. 
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Figure 5.4 

 
 
5. Choose all of the needed parameters in the Quick Marker 

Search Dialog as shown above. In the case of chosen 
parameters (the Select only fixed markers check box is 
turned on), only fixed markers will be copied. 

 
6. Click the OK control button. Four bitmaps with 

markers will be created (wind-off reference, wind-on 
reference, wind-off sensitive, and wind-on 
sensitive). Use the Image command from the View menu 
to switch between these bitmaps. 
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Figure 5.5 

 
 
7. Choose the Automatic Marking... command from the B Convert 

menu. The Quick Marker Search Dialog will appear on your 
screen again. 

 
8. Turn off the Select only fixed markers check box; type “7” 

in the Markers Radius text box; and click the OK control 
button. The number of markers will more than Markers 
Radius is equal to “2”. 

Figure 5.6 
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9. Choose the Automatic Marking... command from the B Convert 
menu. The Quick Marker Search Dialog will appear on your 
screen again. 

10. Turn on the Output As Is radio button in the Output pane 
and the Entropy Based radio button in the Threshold pane. 
Click the OK control button. The number of markers 
will increase. 

Figure 5.7 

 
 

11. Choose the BackGround Work... command from the B Convert 
menu to remove the background on the bitmaps. The 
BackGround Select/Compensate Dialog will appear on your 
screen. 
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Figure 5.8 

 
 

12. Choose all of the needed parameters in the BackGround 
Select/Compensate Dialog as shown above.  

 
13. Click the OK control button. All of the intensities 

on the bitmaps that are less than 500 will become 
background. 
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Figure 5.8 

 
 

14. Choose the BackGround Work... command from the B Convert 
menu. The BackGround Select/Compensate Dialog will appear on 
your screen again. 

 
15. Turn on the by Scaled Image Average radio button, and type 

“0.5” in the Scale text box in the BackGround Select pane. 
Click the OK control button. All of the intensities 
on the bitmaps that are less than one-half of the 
average intensity will become background. 

Figure 5.9 
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16. Choose the BackGround Work... command from the B Convert 
menu. The BackGround Select/Compensate Dialog will appear on 
your screen again. 

 
17. Turn off the BackGround Select check box, and turn on 

the BackGround Compensate check box in the Mode of Operation 
pane. Type “60” in the Value text box. Click the OK 
control button. All of the intensities on the 
bitmaps will be diminished by 60. 

Figure 5.10 

 
 

18. Choose the BackGround Work... command from the B Convert 
menu. The BackGround Select/Compensate Dialog will appear on 
your screen again. 

 
19. Turn on the by 2 Sides Strap Interpolation radio button, and 

type “50” in the Side Straps Width text box in the 
BackGround Compensate pane. Click the OK control button.  
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Figure 5.11 

 
 

20. Choose the Alignment Images... command from the B Convert 
menu to align the bitmaps. The Image Alignment Dialog will 
appear on your screen. 

Figure 5.12 

 
 

21. Choose all of the needed parameters in the Image 
Alignment Dialog as shown above.  

 



ProImage User's GUIDE 47 

22. Click the OK control button. Warning messages about 
the transformation error will appear on the screen.  

 
23. Click the OK control button, or press Enter. Four 

aligned bitmaps will be created (wind-off reference, 
wind-on reference, wind-off sensitive, and wind-on 
sensitive). Use the Image command from the View menu 
to switch between these bitmaps. 

Figure 5.13 

 
 

24. Choose the Image Convert command from the B Convert menu 
to transform the intensity on the aligned bitmaps to 
the physical parameters. Four bitmaps will be 
created (ratio of the intensity on reference bitmap 
to the intensity on the sensitive bitmap, pressure, 
ratio of the pressure to the static pressure, and 
Cp). Use the Image command from the View menu to 
switch between these bitmaps. The Cp flowfield is 
shown below. 



ProImage User's GUIDE 48 

Figure 5.14 

 
 

25. Choose the Resection... command from the B Convert menu to 
map 2D bitmaps (with physical parameters) on the 3D 
mesh that describes the model surface. Then the 
Resection Methods Dialog will appear on your screen. 

Figure 5.15 

 
 

26. Choose all of the needed parameters in the Resection 
Methods Dialog as shown above.  

 
27. Click the OK control button. The Image Alignment Dialog 

will appear on your screen. 
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Figure 5.16 

 
 

28. Choose all of the needed parameters in the Image 
Alignment Dialog as shown above.  

 
29. Click the OK control button. Wwarning messages about 

the transformation error will appear on the screen.  
 

30. Click the OK control button, or press Enter. The 3D 
flowfields will be created. For visualization it is 
necessary to open the file STEP_5.XYZ (it is created 
at Step 31) using the ProField application. An 
inaccurate Flowfield is caused by poor Alignment and 
poor Resection. The violet parts of the Flowfield 
are attributed to background due to discrepancy.  
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Figure 5.17 

 
 

31. Choose the Save Results command from the B Convert menu to 
save the active project and the results of the data 
processing. Four bitmaps will be written on the disk 
(STEP_5_P_TO_PST.IMP, STEP_5_IREFE_ISENS.IMP, 
STEP_5_PRESSURE.IMP, and STEP_5_CP.IMP). These files 
contain the bitmaps of the physical parameters and 
the markers on them. Also the file with 3D 
flowfields will be written on the disk (STEP_5.XYZ).  

 
32. Choose the Close Project command from the B Convert menu 

to close the project file.  
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Chapter 3. Editing a Single Bitmap 
 

Step 6. Editing the Intensity Values on a Bitmap 
 
1. After running ProImage open an existing bitmap 

STEP_6.P that is located in subfolder SAMPLES\STEP_6 
of the current folder: 

• Choose the Open... command from the File menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 6.1 

 
The standard Open Dialog will appear on your screen. 

Figure 6.2 

 
 
2. Choose the file STEP_6.P, and click the Open control 

button. The Open Dialog will be closed, and the bitmap 
will appear on your screen. 
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Figure 6.3 

 
 
3. Choose the Arithmetic... command from the Edit menu. The 

Arithmetic Operations with Constant Dialog will appear on your 
screen. 

Figure 6.4 

 
 
4. Choose all of the needed parameters in the Arithmetic 

Operations with Constant Dialog as shown above.  
 
5. Click the OK control button. The palette in the 

right-hand portion of the application window will be 
changed, and the level of intensity on the bitmap 
will be increased by 10. 
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Figure 6.5 

 
 
6. To create a mask region on the bitmap: 

Choose the Mask by Boxes command from the Mask menu, 

or 

Click the following icon from the upper toolbar: 

Figure 6.6 

 

The cursor shape will be changed to . 
 
7. Press the left mouse button, and move the mouse. 

Choose the desired box size, and release the mouse. 
The selected part of bitmap will be represented with 
bright colors and the out-mask region with muted 
colors. 
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Figure 6.7 

 
 
8. Repeat Step 6-7, and create an additional mask 

region on the bitmap. 

Figure 6.8 

 
 
9. Choose the Flood in Masked Regions... command from the Edit 

menu. The Flood In Masked Region With User Defined Value Dialog will 
appear on your screen. 
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Figure 6.9 

 
 

10. Choose all of the needed parameters in the Flood In 
Masked Region With User Defined Value Dialog as shown above.  

 
11. Click the OK control button. The intensity in the 

masked regions will be equal to 15. 

Figure 6.10 

 
 

12. Choose the Close command from the File menu to close 
the bitmap.  

 
13. Open an existing file STEP_6.P again (or more 

information see Steps 1-2). Figure 6.3 will appear on 
your screen. 

 
14. Choose the Cut Off Intensities... command from the Edit menu. 

The Cut Off Intensities Dialog will appear on your screen. 
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Figure 6.11 

 
 

15. Choose all of the needed parameters in the Cut Off 
Intensities Dialog as shown above.  

 
16. Click the OK control button. The palette in the 

right-hand portion of the application window will be 
changed, and the limits of intensity on the bitmap 
will be equal to 0.2 and 0.9. 

Figure 6.12 

 
 

17. To rotate the bitmap choose the Flip/Rotate... command 
from the Edit menu. The Flip/Rotate Dialog will appear on 
your screen. 
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Figure 6.13 

 
 

18. Choose all of the needed parameters in the Flip/Rotate 
Dialog as shown above.  

 
19. Click the OK control button. The bitmap will be 

rotated. 

Figure 6.14 

 
 

20. To create a mask region on the bitmap: 
Choose the Mask by Polygon command from the Mask menu, 

or 

Click the following icon from the upper toolbar: 

Figure 6.15 

 
The cursor shape will be changed to . 
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21. Click the mouse to fix the polyline nodes at some 

points. Click the mouse at the first node to close 
the polyline. The cursor shape will be changed to 

. Click inside (outside) the polygon. The inner 
(outer) region of the bitmap will be represented 
with bright colors and the out-mask region with 
muted colors. 

Figure 6.16 

 
 

22. Choose the Fill Up... command from the Edit menu. The Eight 
Connected Float Fill Up Dialog will appear on your screen. 

Figure 6.17 
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23. Choose all of the needed parameters in the Eight 
Connected Float Fill Up Dialog as shown above.  

 
24. Click the OK control button. The intensity in the 

masked region will be changed using bilinear 
interpolation. 

Figure 6.18 

 
 

25. Choose the Close command from the File menu to close 
the bitmap.  

 
26. Open an existing file STEP_6.P again (for additional 

information see Steps 1-2). Figure 6.3 will appear on 
your screen. 

 
27. Open an existing file with coordinates of the 

markers STEP_6.MRK that is located in the same 
folder. Choose the Open Markers... command from the 
Markers menu. The standard Open Dialog will appear on 
your screen. 
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Figure 6.19 

 
 

28. Choose the file STEP_6.MRK, and click the Open 
control button. The Open Dialog will be closed, and the 
markers on the bitmap will appear on your screen. 

Figure 6.20 

 
 

29. To add new markers: 

• Choose the Mark... command from the Markers menu, 

or 

• Click the following icon from the upper toolbar: 
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Figure 6.21 

 
The Mark Options Dialog will appear on your screen. 

Figure 6.22 

 
 

30. Choose all of the needed parameters in the Mark Options 
Dialog as shown above.  

 
31. Click the OK control button. The cursor shape is 

changed to . Click at the points on the bitmap, 
and the markers will be placed at these points. 

Figure 6.23 

 
 

32. To turn off the regime of markers selected, choose 
the Mark... command from the Markers menu again.  
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33. To hide the images of the markers on the bitmap, 
choose the Hide Markers command from the Markers menu.  

Figure 6.24 

 
 

34. To remove the dark spots of the marker images from 
the bitmap, choose the Fill Up Markers... command from the 
Edit menu. The Fill Up Markers Dialog will appear on your 
screen. 

Figure 6.25 

 
 

35. Choose all of the needed parameters in the Fill Up 
Markers Dialog as shown above.  

 
36. Click the OK control button. The regions of the 

markers will be bi-interpolated using region 
boundary points on the bitmap. (The region of the 
marker is the circle with the center at the point 
where the marker has been placed.) 
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Figure 6.26 

 
 

37. Create mask regions on the bitmap (for additional 
information see Steps 6-7). 

Figure 6.27 

 
 

38. Choose the Flat Filter... command from the Edit menu. The 
Flat Round Filter Dialog will appear on your screen. 
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Figure 6.28 

 
 

39. Choose all of the needed parameters in the Flat Round 
Filter Dialog as shown above.  

 
40. Click the OK control button. The intensity in the 

masked regions will be changed using the flat 
filter. 

Figure 6.29 

 
 

41. Choose the Close command from the File menu to close 
the bitmap.  

 
42. Open an existing file STEP_6.P again (for additional 

information see Steps 1-2). Figure 6.3 will appear on 
your screen. 

 
43. Choose the Gauss Filter... command from the Edit menu. The 

Gaussian Filter Dialog will appear on your screen. 
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Figure 6.31 

 
 

44. Choose all of the needed parameters in the Gaussian 
Filter Dialog as shown above.  

 
45. Click the OK control button. The intensity on the 

bitmap will be changed using the Gauss filter. 

Figure 6.32 

 
 

46. Choose the Close command from the File menu to close 
the bitmap.  

 
47. Open an existing file STEP_6.P again (for additional 

information see Steps 1-2). Figure 6.3 will appear on 
your screen. 

 
48. Create mask regions on the bitmap (for additional 

information see Steps 6-7.) 
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Figure 6.33 

 
 

49. Choose the Median Filter... command from the Edit menu. The 
Median Filter Dialog will appear on your screen. 

Figure 6.34 

 
 

50. Choose all of the needed parameters in the Median Filter 
Dialog as shown above.  

 
51. Click the OK control button. The intensity in the 

masked regions will be changed using the median 
filter. 
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Figure 6.35 

 
 

52. Choose the Ranged Filter... command from the Edit menu. The 
Ranged Filter Dialog will appear on your screen. 

Figure 6.36 

 
 

53. Choose all of the needed parameters in the Ranged Filter 
Dialog as shown above.  

 
54. Click the OK control button. The intensity in the 

masked regions will be filtrated. 
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Figure 6.37 

 
 
55.To undo the mask selection: 

Choose the Mask All command from the Mask menu, 

or 

Click the following icon from the upper toolbar: 

Figure 6.38 

 
The entire bitmap will be represented with bright 
colors. 
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Figure 6.39 

 
 

56. Choose the 3D Filter... command from the Edit menu. The 3D 
Round Gaussian Filter Dialog will appear on your screen. 

Figure 6.40 

 
 

57. Choose all of the needed parameters in the 3D Round 
Gaussian Filter Dialog as shown above.  

 
58. Click the OK control button. The intensity in the 

masked regions will be filtrated. 
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Figure 6.41 

 
 

59. Choose the Thinning... command from the Edit menu. The 
Thinning Dialog will appear on your screen. 

Figure 6.42 

 
 

60. Choose all of the needed parameters in the Thinning 
Dialog as shown above.  

 
61. Click the OK control button.  
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Figure 6.43 

 
 

62. Choose the Expansion... command from the Edit menu. The 
Spread Dialog will appear on your screen. 

Figure 6.44 

 
 

63. Choose all of the needed parameters in the Spread Dialog 
as shown above.  

 
64. Click the OK control button.  
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Figure 6.45 

 
 
65. Choose the Weighted Hybrid Map... command from the Edit 

menu. The Image Histogram Dialog will appear on your 
screen. 

Figure 6.46 

 
 

66. Choose all of the needed parameters in the Image 
Histogram Dialog as shown above.  

 
67. Click the OK control button.  
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Figure 6.47 
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Step 7. Removing Background from a Bitmap 
 
1. After running ProImage, open an existing bitmap 

STEP_7.B16 that is located in the subfolder 
SAMPLES\STEP_7 of the current folder (for additional 
information see Steps 1-2 of Step 6). 

Figure 7.1 

 
 
2. Choose the BackGround... command from the Tools menu to 

remove the background on the bitmap. The BackGround 
Select/Compensate Dialog will appear on your screen. 
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Figure 7.2 

 
 
3. Choose all of the needed parameters in the BackGround 

Select/Compensate Dialog as shown above.  
 
4. Click the OK control button. All of the intensities 

on the bitmaps that are less than the average 
intensity will be background. 
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Figure 7.3 

 
 
5. Choose the BackGround... command from the Tools menu. The 

BackGround Select/Compensate Dialog will appear on your 
screen again. 

 
6. Turn on the by Threshold Value radio button, and type 

“1000” in the Threshold Value text box in the BackGround 
Select pane. Click the OK control button. All of the  
intensities on the bitmap that are less than 1000 
will become background. 

Figure 7.4 
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7. Choose the BackGround... command from the Tools menu. The 
BackGround Select/Compensate Dialog will appear on your 
screen again. 

 
8. Turn on the by Scaled Image Average radio button, and type 

“0.5” in the Scale text box in the BackGround Select pane. 
Click the OK control button. All of the intensities 
on the bitmap that are less than one-half of the 
average intensity will be background. 

Figure 7.5 

 
 
9. Choose the BackGround... command from the Tools menu. The 

BackGround Select/Compensate Dialog will appear on your 
screen again. 

 
10. Turn off the BackGround Select check box, and turn on 

the BackGround Compensate check box in the Mode of Operation 
pane. Turn on the by Value radio button, and type 
“300” in the Value text box. Click the OK control 
button. The palette in the right-hand portion of the 
application window will be changed, and all of the 
intensities on the bitmap will be diminished by 300.  
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Figure 7.4 

 
 

11. Choose the BackGround... command from the Tools menu. The 
BackGround Select/Compensate Dialog will appear on your 
screen again. 

 
12. Turn on the by 2 Sides Strap Interpolation radio button, and 

type “100” in the Side Straps Width text box in the 
BackGround Compensate pane. Click the OK control button. 
The bitmap will be corrected. 

Figure 7.5 
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Chapter 4. Preparing Project File for ProField Application 
 

Step 8. Preparing a File for ProField Application 
 
The subfolder SAMPLES\STEP_8 of the current folder 
contains all of the files necessary to process the 
project (for additional information see Step 2). 
 
1. Open an existing file STEP_8.IMS that is located in 

the subfolder SAMPLES\STEP_8 of the current folder 
(for additional information see Steps 1-2 of 
Step 2). The wind-on sensitive bitmap will appear on 
your screen. 

Figure 8.1 

 
 
2. Repeat Steps 3-4 of Step 2 with the same parameters.  
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Figure 8.2 

 
 
3. Choose the Automatic Marking... command from the B Convert 

menu. The Quick Marker Search Dialog will appear on your 
screen. 
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Figure 8.3 

 
 
4. Choose all of the needed parameters in the Quick Marker 

Search Dialog as shown above.  
 
5. Click the OK control button. Four bitmaps with 

markers will be created (wind-off reference, wind-on 
reference, wind-off sensitive, and wind-on 
sensitive). Use the Image command from the View menu 
to switch between these bitmaps. 

 
6. Repeat Steps 8-21 of Step 2 with the same 

parameters.  
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Figure 8.4 

 
 
7. To restore the 3D Flowfields from all of the project 

bitmaps, choose the Resection... command from the OMS 
Field menu. The Resection Methods Dialog will appear on your 
screen. 

Figure 8.5 

 
 
8. Choose all of the needed parameters in the Resection 

Methods Dialog as shown above.  

Note. It is recommended that the Resect 1 be used when 
3D markers are measured with mean accuracy. In this 
case the Resect 1 yields a reliable solution. It is 
recommended that the Resect 2 be used when the 3D 
markers are measured with extremely high accuracy. 
Although the Resect 2 yields a more exact solution 
than Resect 1, the solution is not so reliable.  

 
9. Click the OK control button. Warning messages about 

the transformation error will appear on the screen.  
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10. Click the OK control button, or press Enter.  
STEP_8.XYZ will be created. It contains 3D 
flowfields that are mapped from the wind-off 
reference, wind-off sensitive, wind-on reference, 
and wind-on sensitive bitmaps. The bitmaps with 
markers are also mapped on the 3D mesh to create 
appropriate 3D Flowfields. 

 
11. Choose the Close Project command from the B Convert menu 

to close the project file.  
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