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Chapter 1. Creation of simple Geometries (using File menu) 
 

Step 1. How to input data at the beginning of work using 
keyboard 
 

Introduction. Use this command as an additional possibility to 
input small data volumes. As a rule, mathematical model of 
geometry is assumed to create with the use of well-known 
construction system, such as UniGraphics. Then this model may be 
converted in some conventional format. Nevertheless, it may 
useful, in some cases, to create necessary templates of grids 
immediately during the experiment or its processing. For this 
purpose, the dialog box below may be used. 

This command permits to input a structured grid in APT or SKL 
formats. But it isn’t as essential restriction. When a non-
structured grid is necessary, you may input an appropriate 
structured grid and, then, convert it to non-structured one. For 
more information see Step 2.) 

Some designation are used in this dialog box. When you input 
three coordinates (Х, Y, Z), you input a point (a node of grid). 
The nodes are combined into lines. To begin input of a new line, 
click the New line radio button and input coordinates of the first 
point of this new line. The lines are combined into patches. To 
begin input of a new patch, click the New patch radio button and 
input coordinates of the first point of the first line of a new 
patch. 

When all the lines of a patch contain the same number of points, 
then a file of APT format will be obtained. When the lines of a 
patch contain different numbers of points, then a file of SKL 
format will be obtained. It should be noted, that SKL format 
can’t be converted into non-structured VRML format. 

A simple editor permits to edit the Geometry immediately during 
the input. For example, if it’s necessary to input the same point 
some times, one may place its coordinates into the Clipboard 
(using the Copy radio button) and duplicate them (using the Copy 
check box). 

 
 
1. After running ProGraph: 

• Choose the New... command from the File menu. 

or 

• Click the following icon from the upper toolbar: 
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Figure 1.1 

 
Then the Regular Input Dialog Box will appear on your 
screen. 

Figure 1.2 

 
 
2. Input the coordinates of the point. Type “0”, “-1” 

and “1” in text boxes as shown below. 

Figure 1.3 

 
 
3. Save the inputted coordinates in keyboard buffer. 

• Click the Input after control button.  

or 
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• Press Enter. 

Note. Inputted coordinates appear in the list above. 
X, Y and Z are the coordinates of this point; K is 
the number or patch, N is the number of section and 
M is the number of point in this section.  

Figure 1.4 

 
 
4. Repeat steps 2-3 to input the coordinates of the 

following points. 

X Y Z 
0 1 1
0 1 -1
0 -1 -1
0 -1 1

Note. The inputted points will appear in the list 
below.  

Figure 1.5 

 
 
5. Click the Cut radio button the in Points pane. It 

permits to turn on regime of working with Clipboard.  
 
6. Select the second point in the list above with the 

use of mouse.  
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Note. You also may click the list and use the 
following keys to move in the list:  

→, ↓ - upward 

↑, ← - downward 

PgUp, Home – to the beginning of the list 

PgDn, End – to the end of the list. 
 
7. Cut the second point into the Clipboard. 

• Click the Cut control button.  

or 

• Press Enter. 

Note. The second point is removed from the list and 
placed into the Clipboard. The rest points are 
renumbered. 

Figure 1.6 

 
 
8. Turn on the Paste check box in the Points pane.  
 
9. Select the last point in the list.  
 
10.Put the content of Clipboard to the end of list. 

• Click the Input after control button.  

or 

• Press Enter. 

Note. The fifth point appears in the list.  
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Figure 1.7 

 
 
11.Input a new content to Clipboard. Type “0”, “2” and 

“2” in text boxes in the Buffer pane. 
 
12.Select the fourth point in the list.  
 
13.Click the Replace radio button in the Points pane to 

replace the selected point with a Clipboard 
contents.  

 
14.Save the inputted coordinates in keyboard buffer. 

• Click the Replace control button.  

or 

• Press Enter. 
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Figure 1.8 

 
 
15.Turn off the Paste check box in the Points pane (click 

it by mouse).  
 
16.Click the New line radio button in the Componentry pane 

to input a new section.  

Figure 1.9 

 
 
17.Click the New line control button. 

or 

Press Enter. 

Note. The first point of a new line is the point 
that has been selected in the first line.  
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Figure 1.10 

 
 
18.Click the Find radio button in the Componentry pane to 

find some inputted point with the use of its 
integer-valued address (K, N and M indices).  

 
19.Then: 

• Click the Find control button. 

or 

• Press Enter. 

Then the Find Dialog Box will appear on your screen.  

Figure 1.11 

 
 
20.Type “1”, “1” and “3” in the text boxes and click 

the Find control button. Then this point will be 
selected in the list of inputted points. 
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Figure 1.12 

 
 
21.Click the OK radio button in Componentry pane to 

finish the input.  
 
22.Then: 

• Click the OK control button. 

or 

• Press Enter. 

Then the Regular Input Dialog Box will be closed and the 
Geometry will appear on your screen. 
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Figure 1.13 
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Step 2. How to open a file containing the Geometry 
 

Introduction. ProGraph uses grids at the geometry surfaces. 
Therefore, some universally recognized geometrical formats are 
absent among formats used by ProGraph (IGS, for example). As a 
rule, grid files are created by the main constructor systems and 
may be used for further work. Among formats listed in this Step, 
DAT (Tecplot©), WRL and STL formats are well-known. APT (SKL) 
format is used as internal one and it is simplification of DAT 
format. So, for successful work with ProGraph, it is necessary to 
master one of well-known constructor system where mathematical 
models of geometry will be created. 

ProGraph uses Geometries created by different geometrical systems 
such as AutoCAD© 14, Tecplot©, UniGraphics©. 

Geometry is preliminary prepared and converted to one of six 
formats: APT, SKL, DAT, WRL, STL or GRD. 
 
1) When APT file is opened, its format remains the same and file 

isn’t converted. Its patches are painted with following 
colors: the first – with a blue, the second – with a green, 
the third – with a red, the fourth – with a white and the 
fifth – with a petunia color. If the number of patches is more 
than five, the color scheme is repeated in period.  

 
2) When SKL file is opened, two cases may take place.  

• Some sections of Geometry have different number of points. 
In this case the file isn’t converted and it appears on your 
screen as a series of sections. The colors of these sections 
correspond to the numbers of patches (see the first point).  

or 

• All sections of Geometry have the same number of points. In 
this case the file is converted to APT one automatically. 
The colors of the patches correspond to its numbers (see the 
first point). 

 
3) When DAT file is opened, three cases may take place.  

• DAT file contains a structured grid only. In this case the 
file is converted to APT one automatically. The colors of 
the patches correspond to the numbers of patches (see the 
first point).  

or 

• DAT file contains a unstructured grid only. In this case the 
file appears on your screen as a number of triangles. The 
colors of the patches correspond to its numbers (see the 
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first point). ProGraph uses only triangles as an element of 
unstructured grid. Another polyhedrons are converted to 
triangles automatically or they aren’t permitted. 

or 

• DAT file contains both structured and unstructured grid. In 
this case the file is converted to unstructured grid and it 
appears on your screen as a number of triangles (see the 
previous point).  

 
4) When WRL file is opened, it is converted to unstructured DAT 

format automatically (see the previous point).  
 
5) When STL file is opened, it is converted to unstructured DAT 

format automatically (see the point 3).  
 
6) When GRD file is opened, it is converted to unstructured DAT 

format automatically (see the point 3).  
 
 
1. To open an existing file STEP_2.APT that is 

presented in subfolder SAMPLES of the current 
folder: 

• Choose the Open... command from the File menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 2.1 

 
Then the standard Open Dialog Box will appear on your 
screen. 

Figure 2.2 
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2. Choose the file STEP_2.APT and click the Open 

control button. Then the Open Dialog Box will be closed 
and the Geometry will appear on your screen. 

Note. One may open several files at once. Choose 
them with the use of Shift or CTRL keys (just as 
Explorer). 

Figure 2.3 
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Step 3. How to append a Geometry file with another one 
 

Introduction. During the work sometimes a necessity to append a 
geometry by some new parts arises. It may be useful when a 
preliminary inputted geometry, for example wing, is deformed and, 
after it, a flap is appended, for example. Of coarse, one may 
perform it otherwise. One may deform the geometry, save the 
results of work as some new files, close ProGraph and run it 
again and open these new and necessary additional files at once 
(for example, wing and flap). Nevertheless, appending procedure 
is more convenient because there are no intermediate actions 
(reading-saving).  

The procedure of appending depends on the format of opened file. 
 
1) When APT file is opened, only APT, SKL or DAT file may be 

appended. A new file is converted in accordance with the rule 
described at Step 2. If appended DAT file contains 
unstructured grid, then whole Geometry is converted into 
unstructured DAT format. If SKL file is appended, then whole 
Geometry is converted into SKL format. 

 
2) When SKL file is opened, only APT or SKL file may be appended. 

A new file is converted in accordance with the rule described 
at Step 2.  

 
3) When unstructured DAT file is opened, only DAT, WRL or STL 

file may be appended. Appended file is converted into 
unstructured DAT format. 

 
4) When WRL file is opened, only DAT, WRL or STL file may be 

appended. Whole Geometry is converted into unstructured DAT 
format 

 
4) When STL file is opened, only DAT, WRL or STL file may be 

appended. Whole Geometry is converted into unstructured DAT 
format 

 
 
1. To append an existing file STEP_3.APT that is 

presented in subfolder SAMPLES of the current folder 
to the existing file STEP_2.APT opened at Step 2: 

• Choose the Append... command from the File menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 3.1 
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Then the standard Open Dialog Box will appear on your 
screen. 

Figure 3.2 

 
 
2. Choose an existing file STEP_3.APT. Then the 

Geometry will appear on your screen. 

Figure 3.3 
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Step 4. How to save a Geometry file on the disk 
 

Introduction. The procedure of saving depends on the format of 
created file.  
 
1) When file of APT format has been created, it may be saved as a 

file of APT, SKL, DAT, WRL or STL format.  
 
2) When file of SKL format has been created, it may be saved as a 

file of SKL format only.  
 
3) When file of unstructured DAT format has been created, it may 

be saved as a file of unstructured DAT, WRL or STL format 
only.  

 
 
1. To save a file created at Step 3 with a new name 

STEP_4.APT to subfolder SAMPLES of the current 
folder: 

• Choose the Save As... command from the File menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 4.1 

 
Then the standard Save As Dialog Box will appear on your 
screen. 

Figure 4.2 
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2. Type “STEP_4” in the File name text box and click the 
Save control button. Then the Save As Dialog Box will be 
closed and the file will be saved with the new name. 

Figure 4.3 
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Chapter 2. Geometry editing (using Edit menu) 
 

Introduction. During the work it is necessary to edit the 
Geometry so to receive the result that is the most acceptable for 
successful processing the experimental data. As a rule, the 
initial Geometry is created to satisfy requirements of different 
users. For example, the same Geometry may be used both in 
calculation and in experiment. Common approaches to Geometry 
sometimes lead to misunderstanding. Some details, which are very 
important for experimental processing are not essential for CFD. 
For example, during processing the PSP experiment, sharp edges on 
wings are of the special importance. As a result, it is necessary 
to compress the grid and to select special patches in these 
zones. 

This Chapter describes how to rebuild and correct grid surfaces 
given by both structured and non-structured files. 

 

 
Step 5. How to capture a patch and to create a block 

 

Introduction. The special attention in ProGraph ideology is 
devoted to a block. If it is necessary to edit only a part of 
Geometry, one should to capture it into the block. In this case, 
most of commands will be applied to this block only. The block 
may contain one or several patches. Yellow color attracts your 
attention to patches included into block.  

 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. To capture the patch: 

• Choose the Patches ~ Capture command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 5.1 

 

Then cursor shape will be changed to . 
 
3. Click the patch. Then the captured patch will be 

painted with a yellow color and its points will be 
represented as blue markers. The captured patch will 
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be inputted to the block and its number will appear 
in Status Bar. 

The patch that is included in block as the second 
one will be represented with green markers, the 
third – with red, the fourth – with white and the 
fifth – with petunia markers. If the number of 
captured patches is more than five, the color scheme 
will be repeated in period. 

Figure 5.2 
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Step 6. How to capture a patch and to add it to the block 
with the use of Input & Add to block command 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. To capture the patch: 

• Choose the Patches ~ Input & Add to block... command from the 
Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 6.1 

 
Then the Input Patch Dialog Box will appear on your screen. 

Figure 6.2 

 
 
3. Choose all needed parameters in the Input Patch Dialog Box 

as shown above. 
 
4. Click the OK control button. Then the captured patch 

will be painted with a yellow color and its points 
will be represented as blue markers. (For more 
information about colors see Step 5.) The captured 
patch will be inputted to the block and its number 
will be in Status Bar. 
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Figure 6.3 
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Step 7. How to capture a patch and to add it to non-empty 
block 
 
1. To add a new patch to the block created at Step 6:  

• Press right mouse button and choose the Add to block 
command from the context menu. 

or 

• Click the following icon from the left toolbar: 

Figure 7.1 

 

Then cursor shape will be changed to . 
 
2. Click the patch. Then the captured patch will be 

painted with a yellow color and its points will be 
represented as green markers. The captured patch 
will be inputted to the block and its number will 
appear in Status Bar. (For more information about 
colors see Step 5.) 

Figure 7.2 
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Step 8. How to remove a patch from the block  
 
1. To remove a patch from the block created at Step 7: 

• Press right mouse button and choose the Remove from 
block command from the context menu. 

or 

• Click the following icon from the left toolbar: 

Figure 8.1 

 

Then cursor shape will be changed to . 
 
2. Click the patch. Then the initial color of removed 

patch will be restored. (For more information about 
colors see Step 2 and Step 5.) The patch isn’t 
deleted from the Geometry and remains on its place. 

Figure 8.2 
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Step 9. A set of one-action operations with block 
 
1. To delete all needed patches included in the block 

created at Step 8: 

• Choose the Patches ~ Block delete command from the Edit 
menu. 

or 

• Click the following icon from the left toolbar: 

Figure 9.1 

 
Only the patches that aren’t included in the block 
remain on your screen. Their colors are changed. 
(For more information about colors see Step 2.) 

Figure 9.2 

 
 
2. To undo all changes:  

• Choose the Patches ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 9.3 

 
Then old Geometry will appear on your screen again. 
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Figure 9.4 

 
 
3. Capture the patch with the number 1. (For more 

information see steps 2-3 of Step 5.)  

Figure 9.5 

 
 
4. To keep all the patches included in the block: 

• Choose the Patches ~ Block extract command from the Edit 
menu. 
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or 

• Click the following icon from the left toolbar: 

Figure 9.6 

 
Only the patches included in the block remain on 
your screen. Their colors may be changed. (For more 
information about colors see Step 2.)  

Figure 9.7 

 
 
5. To undo all changes choose the Patches ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 
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Figure 9.8 
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Step 10. How to convert files to another format 
 

Introduction. In ProGraph the main attention is paid on editing 
structured grid surfaces. So, during the work with non-structured 
grids, it is convenient to convert them into structured format 
(APT). It permits to use many commands of ProGraph. When it is 
necessary, structured grid may be easily converted back into non-
structured grid format (VRML)  

 
 
1. Open an existing file STEP_10.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 10.1 

 
 
2. To convert this file to DAT format: 

• Choose the Convert to ~ VRML or DAT command from the 
Transformations menu. 

or 

• Click the following icon from the right toolbar: 

Figure 10.2 

 
Then the file of DAT format will appear on your 
screen. 
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Figure 10.3 

 
 
3. To convert this file to SKL format: 

• Choose the Convert to ~ SKL... command from the 
Transformations menu. 

or 

• Click the following icon from the right toolbar: 

Figure 10.4 

 
Then the Convert to SKL Dialog Box will appear on your 
screen. 

 
4. Choose all needed parameters in the Convert to SKL Dialog 

Box as shown below. 
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Figure 10.5 

 
 
5. Click the OK control button. Then the file of SKL 

format will appear on your screen. 

Figure 10.6 

 
 
6. To undo all changes: 

• Choose the Patches ~ Undo command from the Edit menu. 

or 
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• Click the following icon from the upper toolbar: 

Figure 10.7 

 
Then old Geometry will appear on your screen again. 

Figure 10.8 

 
 
7. Choose the Convert to ~ SKL... command from the Transformations 

menu again. Then the Convert to SKL Dialog Box will appear 
on your screen. 

 
8. Choose all needed parameters in the Convert to SKL Dialog 

Box as shown below. 
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Figure 10.9 

 
 
9. Click the OK control button. Then the file of SKL 

format will appear on your screen. 

Figure 10.10 

 
 
10.To undo all changes choose the Patches ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 
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Figure 10.11 

 
 
11.Choose the Convert to ~ SKL... command from the 

Transformations menu again. Then the Convert to SKL Dialog Box 
will appear on your screen. 

 
12.Choose all needed parameters in the Convert to SKL Dialog 

Box as shown below. 

Figure 10.12 
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13.Click the OK control button. Then the file of SKL 
format will appear on your screen. 

Figure 10.13 

 
 
14.To convert this file to APT format: 

• Choose the Convert to ~ APT... command from the 
Transformations menu. 

or 

• Click the following icon from the right toolbar: 

Figure 10.14 

 
Then the Convert to APT Dialog Box will appear on your 
screen. 

Figure 10.15 
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15.Choose all needed parameters in the Convert to APT Dialog 
Box as shown above. 

 
16.Click the OK control button. Then the file of APT 

format will appear on your screen. 

Figure 10.16 
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Step 11. How to capture a section 
 

Introduction. The special attention in ProGraph ideology is 
devoted sections and lines (structured grid). For example, 
sections are fuselage frames and lines are fuselage stringers. 
Mathematically, sections correspond to columns of matrix that 
defines the Geometry grid and lines correspond to its rows. 

In some cases, the Geometry is defined partly. For example, the 
Geometry is given by reading a sketch using Digitizer. Then each 
section may contain arbitrary number of points (the matrix isn’t 
filled in). In this case, there are sections but there are no 
lines (SKL format). 

Section (line) capturing is the first operation in local editing 
the Geometry. After section (line) capturing, all the commands 
that are available in right-mouse menu will act on captured 
section (line) only. For example, one can capture a point that 
belongs to captured section (line) only. 

This Step describes one of the most frequently used procedures - 
how to capture a section. 

 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. To capture the section: 

• Choose the Lines ~ Capture ~ Section command from the Edit 
menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 11.1 

 

Then cursor shape will be changed to . 
 
3. Then: 

• Press left mouse button and drag the mouse. The 
points of section under cursor will be painted 
with a white color and section and patch numbers 
will appear in Status Bar. Releasing the mouse 
button captures the section.  

or 

• Click the section. 
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Then the points of captured section will be painted 
with a white color. 

When a block has been created, only a section 
belonging to this block may be captured. When no 
patches are included in the block, any section may 
be captured. 

Figure 11.2 
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Step 12. How to capture a section with the use of 
Input ~ Section command 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. To capture the section: 

• Choose the Lines ~ Input ~ Section... command from the Edit 
menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 12.1 

 
Then the Input section Dialog Box will appear on your 
screen. 

 
3. Choose all needed parameters in the Input section Dialog Box 

as shown below. 

Figure 12.2 

 
 
4. Click the OK control button. The points of captured 

section are painted with a white color and section 
and patch numbers appear in Status Bar. 

When a block has been created, only a section 
belonging to this block may be captured. When no 
patches are included in the block, any section may 
be captured. 
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Figure 12.3 
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Step 13. How to capture a line 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. To capture the line: 

• Choose the Lines ~ Capture ~ Line command from the Edit 
menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 13.1 

 

Then cursor shape will be changed to . 
 
3. Then: 

• Press left mouse button and drag the mouse. The 
points of line under cursor will be painted with a 
white color and line and patch numbers will appear 
in Status Bar. Releasing the mouse button captures 
the line.  

or 

• Click the line. 

Then the points of captured line will be painted 
with a white color. 

When a block has been created, only a line belonging 
to this block may be captured. When no patches are 
included in the block, any line may be captured. 
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Figure 13.2 
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Step 14. How to capture a line with the use of Input ~ Line 
command 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. To capture the line: 

• Choose the Lines ~ Input ~ Line... command from the Edit 
menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 14.1 

 
Then the Input line Dialog Box will appear on your screen. 

 
3. Choose all needed parameters in the Input line Dialog Box 

as shown below. 

Figure 14.2 

 
 
4. Click the OK control button. The points of captured 

line are painted with a white color and line and 
patch numbers appear in Status Bar. 

When a block has been created, only a line belonging 
to this block may be captured. When no patches are 
included in the block, any line may be captured. 
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Figure 14.3 
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Step 15. How to split a patch on two patches 
 

Introduction. During the work with ProGraph, sometimes it is 
necessary to create additional patches. We recommend you to do it 
when you need to select the Geometry part for detailed 
approximation of this zone during processing the experimental 
data.  

This Step describes how to create additional patches, in the case 
of structured Geometry grid. In the case of non-structured grid, 
it is recommended to convert it into a structured format as it is 
shown in Step 10. 

 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. Capture a section. (For more information see steps 

2-3 of Step 11.) 

Figure 15.1 

 
 
3. To split a patch on two patches:  

• Press right mouse button and choose the Split patch in 
block command from the context menu. 

or 

• Click the following icon from the left toolbar: 
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Figure 15.2 

 
Then the patch that contains the captured section 
will be split. This section is used as a border of 
two new patches. The captured section belongs to 
both patches. The colors of patches will be changed. 
(For more information about colors see Step 2.) 

Figure 15.3 
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Step 16. A set of one-action operations with sections  
 

Introduction. In this Step the most frequently used commands are 
described. Use them for Geometry editing. 

 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. Capture a section. (For more information see steps 

2-3 of Step 11.) 

Figure 16.1 

 
 
3. To delete the captured section: 

• Press right mouse button and choose the Delete 
command from the context menu. 

or 

• Click the following icon from the left toolbar: 

Figure 16.2 

 
Then the captured section will be deleted. The next 
section becomes the captured one. 
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Figure 16.3 

 
 
4. To undo all changes: 

• Choose the Lines ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 16.4 

 
Then old Geometry will appear on your screen again. 
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Figure 16.5 

 
 
5. To copy the captured section: 

• Press right mouse button and choose the Duplicate... 
command from the context menu. 

or 

• Click the following icon from the left toolbar: 

Figure 16.6 

 
Then the Duplicate Dialog Box will appear on your screen. 

 
6. Choose all needed parameters in the Duplicate Dialog Box 

as shown below. 

Figure 16.7 

 
 
7. Click the OK control button. Then the captured 

section will be duplicated and its points will be 
distinguished as a white markers with green border. 
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Figure 16.8 

 
 
8. To undo all changes choose the Lines ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 16.9 

 
 
9. To copy the captured section to Clipboard: 

• Press right mouse button and choose the Copy 
command from the context menu. 
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or 

• Click the following icon from the left toolbar: 

Figure 16.10 

 
Then the captured section will be copied to 
Clipboard. It may be placed at any position. 

 
10.To capture another section press right mouse button, 

choose the Next Section (Line) command from the context 
menu and capture necessary section. (For more 
information see steps 2-3 of Step 11.) 

Figure 16.11 

 
 
11.To place the Clipboard content instead of the 

captured section: 

• Press right mouse button and choose the Paste 
command from the context menu. 

or 

• Click the following icon from the left toolbar: 

Figure 16.12 

 
Then the Clipboard content will replace the captured 
section. 
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Figure 16.13 
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Step 17. How to rebreak a section 
 

Introduction. This command is used most often for practical work. 
It should be noted that Geometry grid may be deviated from 
initial one because of this command implementation. It is because 
smoothing splines act in the framework of some accuracy. So, 
there is a complex problem: either to agree with oscillations of 
function defined surface grids or to smooth the Geometry and, 
hence, to distort it slightly. 

This Step contains some examples how to use numerous 
possibilities of the command. 

 
 
1. Open an existing file STEP_17a.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) Then the 
Geometry will appear on your screen. 

Figure 17.1 

 
 
2. Capture the second section of a green patch. (For 

more information see steps 2-3 of Step 11.) 
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Figure 17.2 

 
 
3. To rebreak the captured section: 

• Press right mouse button and choose the Rebreak... 
command from the context menu. 

or 

• Click the following icon from the left toolbar: 

Figure 17.3 

 
Then the Rebreak Dialog Box will appear on your screen. 

 
4. Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 
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Figure 17.4 

 
 
5. Click the OK control button. Then the captured 

section will be rebroken. 

Figure 17.5 

 
 
6. To undo all changes: 

• Choose the Lines ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 
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Figure 17.7 

 
Then old Geometry will appear on your screen again. 

 
7. To rebreak another section press right mouse button 

and choose the Rebreak... command from the context menu 
again. Then the Rebreak Dialog Box will appear on your 
screen. 

 
8. Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 

Figure 17.8 

 
 
9. Click the OK control button. Then the fourth section 

will be rebroken. It will become the captured one. 
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Figure 17.9 

 
 
10.To undo all changes choose the Lines ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 17.10 

 
 
11.To rebreak all sections of the patch press right 

mouse button and choose the Rebreak... command from the 
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context menu again. Then the Rebreak Dialog Box will 
appear on your screen. 

 
12.Choose all needed parameters in the Rebreak Dialog Box 

as shown below. 

Figure 17.11 

 
 
13.Click the OK control button. Then all the sections 

of green patch will be rebroken.  

Figure 17.12 
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14.To undo all changes choose the Lines ~ Undo command 
from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 17.13 

 
 
15.To rebreak the green patch in some range press right 

mouse button and choose the Rebreak... command from the 
context menu again. Then the Rebreak Dialog Box will 
appear on your screen. 

 
16.Choose all needed parameters in the Rebreak Dialog Box 

as shown below. 
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Figure 17.14 

 
 
17.Click the OK control button. Then the green patch 

in the range from the fifth line to the tenth line 
will be rebroken.  

Figure 17.15 

 
 
18.To undo all changes choose the Lines ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 
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Figure 17.16 

 
 
19.To rebreak the second and the third sections of 

green patch press right mouse button and choose the 
Rebreak... command from the context menu again. Then 
the Rebreak Dialog Box will appear on your screen. 

 
20.Choose all needed parameters in the Rebreak Dialog Box 

as shown below. 

Figure 17.17 
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21.Click the OK control button. Then the second and 
the third sections of green patch will be rebroken.  

Figure 17.18 

 
 
22.To undo all changes choose the Lines ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 17.19 
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23.To rebreak the second and the third sections of 
green patch press right mouse button and choose the 
Rebreak... command from the context menu again. Then 
the Rebreak Dialog Box will appear on your screen. 

 
24.Choose all needed parameters in the Rebreak Dialog Box 

as shown below. 

Figure 17.20  

 
 
25.Click the OK control button. Then the second and 

the third sections of green patch will be rebroken 
with new number of points.  

Note. APT format of opened file is violated. 
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Figure 17.21 

 
 
26.Open an existing file STEP_17b.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) Then the 
Geometry will appear on your screen. 

Figure 17.22 

 
 
27.Capture the second section of a green patch. (For 

more information see steps 2-3 of Step 11.) 
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Figure 17.23 

 
 
28.To rebreak all sections of green patch in accordance 

with the captured section press right mouse button 
and choose the Rebreak... command from the context 
menu. Then the Rebreak Dialog Box will appear on your 
screen. 

 
29.Choose all needed parameters in the Rebreak Dialog Box 

as shown below. 

Figure 17.24 
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30.Click the OK control button. Then all sections of 

green patch will be rebroken in accordance with the 
captured section.  

Figure 17.25 

 
 
31.Open an existing file STEP_17c.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) Then the 
Geometry will appear on your screen. 
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Figure 17.26 

 
 
32.Capture the last section. (For more information see 

steps 2-3 of Step 11.) 

Figure 17.27 

 
 
33.Press right mouse button and choose the Rebreak... 

command from the context menu. Then the Rebreak Dialog 
Box will appear on your screen. 
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34.Choose all needed parameters in the Rebreak Dialog Box 
as shown below. 

Figure 17.28 

 
 
35.Click the OK control button. Then new Geometry will 

appear on your screen. 

Figure 17.29 

 
 
36.Open an existing file STEP_17d.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
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more information see steps 1-2 of Step 2.) Then the 
Geometry will appear on your screen. 

Figure 17.30 

 
 
37.Capture the ninth line of green patch. (For more 

information see steps 2-3 of Step 13.) 

Figure 17.31 

 
 
38.To change the number of sections in green patch 

press right mouse button and choose the Rebreak... 
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command from the context menu. Then the Rebreak Dialog 
Box will appear on your screen. 

 
39.Choose all needed parameters in the Rebreak Dialog Box 

as shown below. 

Figure 17.32 

 
 
40.Click the OK control button. Then new Geometry will 

appear on your screen. 

Figure 17.33 
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41.To undo all changes choose the Lines ~ Undo command 
from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 17.34 

 
 
42.Press right mouse button and choose the Rebreak... 

command from the context menu. Then the Rebreak Dialog 
Box will appear on your screen. 

 
43.Choose all needed parameters in the Rebreak Dialog Box 

as shown below. 
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Figure 17.35 

 
 
44.Click the OK control button. Then new Geometry will 

appear on your screen. 

Figure 17.36 
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Step 18. How to capture a point 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. To capture the point: 

• Choose the Point ~ Capture command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 18.1 

 

Then cursor shape will be changed to . 
 
3. Then: 

• Press left mouse button and drag the mouse. The 
point under cursor will be distinguished as a 
white marker with red border and its number will 
appear in Status Bar. Releasing the mouse button 
captures the point.  

or 

• Click the point. 

Then the captured point will be distinguished as a 
white marker with red border. 

When a block has been created, only a point 
belonging to this block may be captured. When a 
section or a line has been captured, only a point 
belonging to this section or line may be captured. 
When no patches, sections or lines have been 
captured, any point may be captured. 
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Figure 18.2 
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Step 19. How to capture a point with the use of Input 
command 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. To capture the section choose the Point ~ Input... command 

from the Edit menu. Then the Find Dialog Box will appear 
on your screen. 

 
3. Choose all needed parameters in the Find Dialog Box as 

shown below. 

Figure 19.1 

 
 
4. Click the OK control button. Then the captured point 

will be distinguished as a white marker with red 
border. 

When a block has been created, only a point 
belonging to this block may be captured. When a 
section or a line has been captured, only a point 
belonging to this section or line may be captured. 
When no patches, sections or lines have been 
captured, any point may be captured. 
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Figure 19.2 
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Step 20. A set of one-action operations with points 
 
1. Open an existing file STEP_2.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

 
2. Capture a point. (For more information see steps 2-3 

of Step 18.) 

Figure 20.1 

 
 
3. To delete the captured point: 

• Choose the Point ~ Delete command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.2 

 
Then the captured point will be deleted. The next 
point will become the captured one.  

Note. APT format of opened file is violated. 
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Figure 20.3 

 
 
4. To undo all changes:  

• Choose the Point ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 20.4 

 
Then old Geometry will appear on your screen again. 
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Figure 20.5 

 
 
5. To copy the captured point: 

• Choose the Point ~ Duplicate... command from the Edit 
menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.6 

 
Then the Duplicate Dialog Box will appear on your screen. 

 
6. Choose all needed parameters in the Duplicate Dialog Box 

as shown below. 

Figure 20.7 

 
 
7. Click the OK control button. Then the captured point 

will be duplicated and distinguished as a green 
markers with red border.  
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Note. APT format of opened file is violated. 

Figure 20.8 

 
 
8. To undo all changes choose the Point ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 20.9 

 
 
9. To copy the captured point to Clipboard: 
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• Choose the Point ~ Copy command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.10 

 
Then the captured point will be copied to Clipboard. 
It may be placed at any position. 

 
10.To capture another point press right mouse button, 

choose the Next point command from the context menu and 
capture necessary section. (For more information see 
steps 2-3 of Step 18.) 

Figure 20.11 

 
 
11.To place the Clipboard content instead of the 

captured point: 

• Choose the Point ~ Paste command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.12 

 
Then the Clipboard content will replace the captured 
point. 
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Figure 20.13 

 
 
12.To undo all changes choose the Point ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 20.14 

 
 
13.To edit the coordinates of the captured point: 

• Choose the Point ~ Edit... command from the Edit menu. 
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or 

• Click the following icon from the left toolbar: 

Figure 20.15 

 
Then the Edit point Dialog Box will appear on your screen. 

 
14.Choose all needed parameters in the Edit point Dialog Box 

as shown below. 

Figure 20.16 

 
 
15.Click the OK control button. Then the captured 

point will be moved.  

Figure 20.17 

 
 
16.To undo all changes choose the Point ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 
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Figure 20.18 

 
 
17.To drag the captured point: 

• Choose the Point ~ Drag command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.19 

 
 
18.Then: 

• Press left mouse button and drag the mouse. The 
captured point will be moved and its new 
coordinates will appear in Status Bar. Releasing 
the mouse button drops the captured point at the 
last position. 

or 

• Click a new position of the captured point. 

Then the captured point is moved in the plane of 
curvilinear quadrangle that is formed by neighboring 
sections and lines. This curvilinear quadrangle is 
covered by a grid that has 100x100 cells. The point 
can be placed in the points of this grid only. The 
point can’t be dragged outside the quadrangle. 
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Figure 20.20 
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Chapter 3. Block transforming (using Transformations menu) 
 
Step 21. How to create a block projection on other patches 

 

Introduction. In many cases, it is convenient to work with files 
that contain structured grid prepared by a special way. 
Nevertheless, the main constructor systems (for example, AutoCAD) 
create structured files using automatic procedures for meshing. 
For more suitable work in these cases, a simple procedure that 
permits to obtain grid on the model surface in the necessary form 
has been developed. 

ProGraph permits to convert one structured grid into another one.  

Such possibility is described in this Step. To its realization an 
algorithm of one-to-another grid reflection has been used. A 
normal is calculated at each node of the template grid and 
coordinates of point where normal intersects the target grid 
surface are determined. As a result, we can receive the surface 
grid that is similar to template but contains all the points 
placed on the target surface. In fact, if template contains 
compression of grid nodes, then result of projection contains 
similar compression too. The template may be created by any 
methods, but it is desirable to create it as close to target 
surface as possible. 

 
1. Open an existing file STEP_21a.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 
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Figure 21.1 

 
 
2. Append an existing file STEP_21b.APT that is 

presented in subfolder SAMPLES of the current 
folder. (For more information see steps 1-2 of 
Step 3.) 

Figure 21.2 

 
 
3. Capture the green patch. (For more information see 

steps 2-3 of Step 5.)  
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Figure 21.3 

 
 
4. To create a projection of block on the other patch: 

• Choose the Projection to APT command from the 
Transformations menu. 

or 

• Click the following icon from the right toolbar: 

Figure 21.4 

 
Then the Geometry will appear on your screen. 
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Figure 21.5 

 
 
5. Keep all the patches included in the block. (For 

more information see step 4 of Step 9.) Only the 
patches included in the block remain on your screen. 
Their colors are changed. (For more information 
about colors see Step 2.) 

Figure 21.6 
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Step 22. How to create an intersection of two patches 
 

Introduction. Quite often, Geometry grids developed with the use 
of constructor systems (UniGraphics, for example) aren’t agreed 
each other. For example, mathematical models of fuselage and wing 
usually are developed separately. In this case, it is necessary 
to perform an additional procedure named as “inset of wing into 
fuselage”. 

This Step describes how to do it.  
 
 
1. Open an existing file STEP_22a.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 22.1 

 
 
2. Append an existing file STEP_22b.APT that is 

presented in subfolder SAMPLES of the current 
folder. (For more information see steps 1-2 of 
Step 3.) 
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Figure 22.2 

 
 
3. To show first points and sections choose the View 

features command from the Options menu. Then the View 
features Dialog Box will appear on your screen. 

 
4. Choose all needed parameters in the View features Dialog 

Box as shown below. 

Figure 22.3 

 
 
5. Click the OK control button. Then first sections 

will be represented with big yellow markers and 
first point at each section will be represented as 
big red markers. 

Note. Patches must be crossed.  
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Figure 22.4 

 
 
6. To set the plane view constY =  click the following 

icon from the upper toolbar . Then a new 
projection of Geometry will appear on your screen. 

Figure 22.5 

 
 
7. Capture the green patch. (For more information see 

steps 2-3 of Step 5.)  
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Figure 22.6 

 
 
8. To intersect these patches and to create smooth 

conjugation of intersecting area: 

• Choose the Intersection... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 22.7 

 
Then the Intersection Dialog Box will appear on your 
screen. 

 
9. Choose all needed parameters in the Intersection Dialog Box 

as shown below. 
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Figure 22.8 

 
 
10.Click the OK control button. Then the Geometry will 

appear on your screen. 

Figure 22.9 

 
 
11.To set the plane view constX =  click the following 

icon from the upper toolbar . Then a new 
projection of Geometry will appear on your screen. 
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Figure 22.10 

 
 



ProGraph User's GUIDE 96 

Step 23. How to merge patches included in the block 
 

Introduction. In Step 15 it has been mentioned that during the 
work it may be necessary to create additional patches. The 
reverse process of creating a united patch from several patches 
is important too.  

This Step describes how to do it. 
 
 
1. Open an existing file STEP_23a.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 23.1 

 
 
2. Capture the green patch. (For more information see 

steps 2-3 of Step 5.) 
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Figure 23.2 

 
 
3. Capture the red patch. (For more information see 

steps 1-2 of Step 7.) 

Figure 23.3 

 
 
4. To merge this patches: 

• Choose the Merge... command from the Transformations 
menu. 
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or 

• Click the following icon from the upper toolbar: 

Figure 23.5 

 
Then the Merge Dialog Box will appear on your screen. 

 
5. Choose all needed parameters in the Merge Dialog Box as 

shown below. 

Figure 23.5 

 
 
6. Click the OK control button. Then the number of 

lines will remain the same and the number of 
sections will increase. Double points will be 
represented with big green markers. The colors of 
patches will be changed. (For more information about 
colors see Step 2.) 
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Figure 23.6 

 
 
7. Open an existing file STEP_23b.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 23.7 

 
 
8. Capture the green patch. (For more information see 

steps 2-3 of Step 5.) 
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Figure 23.8 

 
 
9. Capture the red patch. (For more information see 

steps 1-2 of Step 7.) 

Figure 23.9 

 
 
10.Choose the Merge... command from the Transformations menu 

again. Then the Merge Dialog Box will appear on your 
screen. 
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11.Choose all needed parameters in the Merge Dialog Box as 
shown below. 

Figure 23.10 

 
 
12.Click the OK control button. The patches in block 

have different numbers of lines. After merging APT 
format will be violated. Then a warning about APT 
format violation will appear on your screen. 

 
13.Click the Yes control button or press Enter. Then a 

new Geometry of SKL format will appear on your 
screen. The sections of block belong to one patch 
now. The colors of patches will be changed. (For 
more information about colors see Step 2.) 
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Figure 23.11 

 
 
14.Open an existing file STEP_23c.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 23.12 

 
 
15.Capture the green patch. (For more information see 

steps 2-3 of Step 5.) 
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Figure 23.13 

 
 
16.Capture the red patch. (For more information see 

steps 1-2 of Step 7.) 

Figure 23.14 

 
 
17.Choose the Merge... command from the Transformations menu 

again. Then the Merge Dialog Box will appear on your 
screen. 
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18.Choose all needed parameters in the Merge Dialog Box as 
shown below. 

Figure 23.15 

 
 
19.Click the OK control button. The points of sections 

in the first and the second patches have different 
distributions.  

A new Geometry appears on your screen. The sections 
of block belong to one patch now. The second patch 
is rebroken in accordance with the first one. The 
colors of patches are changed. (For more information 
about colors see Step 2.) 
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Figure 23.16 

 
 
20.Open an existing file STEP_23d.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 23.17 

 
 
21.Capture the red patch. (For more information see 

steps 2-3 of Step 5.) 



ProGraph User's GUIDE 106 

Figure 23.18 

 
 
22.Capture the green patch. (For more information see 

steps 1-2 of Step 7.) 

Figure 23.19 

 
 
23.Choose the Merge... command from the Transformations menu 

again. Then the Merge Dialog Box will appear on your 
screen. 
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24.Choose all needed parameters in the Merge Dialog Box as 
shown below. 

Figure 23.20 

 
 
25.Click the OK control button. Then the number of 

sections will remain the same and the number of 
lines will increase. The colors of patches will be 
changed. (For more information about colors see 
Step 2.) 

Figure 23.21 
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Step 24. A set of one-action transformations of block 
 
1. Open an existing file STEP_10.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 24.1 

 
 
2. Capture the green patch. (For more information see 

steps 2-3 of Step 5.)  
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Figure 24.2 

 
 
3. To scale the block: 

• Choose the Scaling... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.3 

 
Then the Scaling Dialog Box will appear on your screen. 

 
4. Choose all needed parameters in the Scaling Dialog Box as 

shown below. 
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Figure 24.4 

 
 
5. Click the OK control button. Then the block will be 

scaled and a new Geometry will appear on your 
screen. 

Figure 24.5 

 
 
6. To undo all changes:  

• Choose the Patches ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 
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Figure 24.6 

 
Then old Geometry will appear on your screen again. 

Figure 24.7 

 
 
7. To move the block: 

• Choose the Move... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.8 

 
Then the Move Dialog Box will appear on your screen. 

 
8. Choose all needed parameters in the Move Dialog Box as 

shown below. 
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Figure 24.9 

 
 
9. Click the OK control button. Then the block will be 

moved and a new Geometry will appear on your screen. 

Figure 24.10 

 
 
10.To undo all changes choose the Patches ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again.  
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Figure 24.11 

 
 
11.To rotate the block: 

• Choose the Rotation... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.12 

 
Then the Rotation Dialog Box will appear on your screen. 

 
12.Choose all needed parameters in the Rotation Dialog Box 

as shown below. 
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Figure 24.13 

 
 
13.Click the OK control button. Then the block will be 

rotated and a new Geometry will appear on your 
screen. 

Figure 24.14 

 
 
14.To undo all changes choose the Patches ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again.  
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Figure 24.15 

 
 
15.To mirror the block: 

• Choose the Flip... command from the Transformations menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.16 

 
Then the Flip Dialog Box will appear on your screen. 

 
16.Choose all needed parameters in the Flip Dialog Box as 

shown below. 

Figure 24.17 
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17.Click the OK control button. Then the block will be 

mirrored and a new Geometry will appear on your 
screen. 

Figure 24.18 

 
 
18.To undo all changes choose the Patches ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again.  

Figure 24.19 
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19.To add symmetrical block to the present one: 

• Choose the Symmetric... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.20 

 
Then the Symmetry Dialog Box will appear on your screen. 

 
20.Choose all needed parameters in the Symmetry Dialog Box 

as shown below. 

Figure 24.21 

 
 
21.Click the OK control button. Then a new Geometry 

will appear on your screen. 
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Figure 24.22 

 
 
22.To undo all changes choose the Patches ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again.  

Figure 24.23 

 
 
23.To halve the number of points in every section of 

block: 
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• Choose the Knife... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.24 

 
Then the Before or After Dialog Box will appear on your 
screen. 

 
24.Choose all needed parameters in the Before or After Dialog 

Box as shown below. 

Figure 24.25 

 
 
25.Click the OK control button. Then a new Geometry 

will appear on your screen. 

Figure 24.26 
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26.To enlarge the linear size of the block press right 
mouse button and choose the Extrapolate... command from 
the Edit menu. Then the Extrapolation Dialog Box will appear 
on your screen. 

 
27.Choose all needed parameters in the Extrapolation Dialog 

Box as shown below. 

Figure 24.27 

 
 
28.Click the OK control button. Then a new Geometry 

will appear on your screen. 

Figure 24.28 
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Chapter 4. Section transforming (using right mouse menu) 
 
Step 25. A set of one-action transformations of section 

 
1. Open an existing file STEP_10.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 25.1 

 
 
2. Capture a section. (For more information see steps 

2-3 of Step 11.)  
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Figure 25.2 

 
 
3. To scale the captured section press right mouse 

button and choose the Scaling... command from the 
context menu. Then the Scaling Dialog Box will appear on 
your screen. 

 
4. Choose all needed parameters in the Scaling Dialog Box as 

shown below. 

Figure 25.3 

 
 
5. Click the OK control button. Then the captured 

section will be scaled and a new Geometry will 
appear on your screen. 



ProGraph User's GUIDE 123 

Figure 25.4 

 
 
6. To undo all changes:  

• Choose the Lines ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 25.5 

 
Then old Geometry will appear on your screen again. 
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Figure 25.6 

 
 
7. To move the captured section press right mouse 

button and choose the Move... command from the context 
menu. Then the Move Dialog Box will appear on your 
screen. 

 
8. Choose all needed parameters in the Move Dialog Box as 

shown below. 

Figure 25.7 

 
 
9. Click the OK control button. Then the captured 

section will be moved and a new Geometry will appear 
on your screen. 
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Figure 25.8 

 
 
10.To undo all changes choose the Lines ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 25.9 

 
 
11.To rotate the captured section press right mouse 

button and choose the Rotation... command from the 
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context menu. Then the Rotation Dialog Box will appear on 
your screen. 

 
12.Choose all needed parameters in the Rotation Dialog Box 

as shown below. 

Figure 25.10 

 
 
13.Click the OK control button. Then the captured 

section will be rotated and a new Geometry will 
appear on your screen. 

Figure 25.11 
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14.To undo all changes choose the Lines ~ Undo command 
from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 25.12 

 
 
15.To mirror the captured section press right mouse 

button and choose the Flip... command from the context 
menu. Then the Flip Dialog Box will appear on your 
screen. 

 
16.Choose all needed parameters in the Flip Dialog Box as 

shown below. 

Figure 25.13 
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17.Click the OK control button. Then the captured 
section will be mirrored and a new Geometry will 
appear on your screen. 

Figure 25.14 

 
 
18.To undo all changes choose the Lines ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 25.15 
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19.To add symmetrical section to the captured one press 
right mouse button and choose the Symmetric... command 
from the context menu. Then the Symmetry Dialog Box will 
appear on your screen. 

 
20.Choose all needed parameters in the Symmetry Dialog Box 

as shown below. 

Figure 25.16 

 
 
21.Click the OK control button. Then a new Geometry 

will appear on your screen. 

Note. APT format of opened file is violated. 

Figure 25.17 
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22.To undo all changes choose the Lines ~ Undo command 
from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 25.18 

 
 
23.To move the captured section with the use of linear 

interpolation press right mouse button and choose 
the Interpolate... command from the context menu. Then the 
Interpolate Dialog Box will appear on your screen. 

 
24.Choose all needed parameters in the Interpolate Dialog Box 

as shown below. 

Figure 25.19 

 
 
25.Click the OK control button. Then the captured 

section will be moved to the next one and a new 
Geometry will appear on your screen. 
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Figure 25.20 

 
 
26.To undo all changes choose the Lines ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 

Figure 25.21 

 
 
27.To prescribe a definite value for coordinate (X, Y 

or Z) of all the points included in the captured 
section press right mouse button and choose the 
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Prescribe... command from the context menu. Then the 
Prescribe Dialog Box will appear on your screen. 

 
28.Choose all needed parameters in the Prescribe Dialog Box 

as shown below. 

Figure 25.22 

 
 
29.Click the OK control button. Then the captured 

section will be moved to the next one and a new 
Geometry will appear on your screen. 

Figure 25.23 

 
 
30.To undo all changes choose the Lines ~ Undo command 

from the Edit menu. Then old Geometry will appear on 
your screen again. 



ProGraph User's GUIDE 133 

Figure 25.24 

 
 
31.To halve the number of points in the captured 

section press right mouse button and choose the 
Knife... command from the context menu. Then the Before or 
After Dialog Box will appear on your screen. 

 
32.Choose all needed parameters in the Before or After Dialog 

Box as shown below. 

Figure 25.25 

 
 
33.Click the OK control button. Then a new Geometry 

will appear on your screen. 

Note. APT format of opened file is violated. 
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Figure 25.26 
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Step 26. A set of one-action transformations of section part 
 
1. Open an existing file STEP_10.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 26.1 

 
 
2. Capture a section. (For more information see steps 

2-3 of Step 11.)  
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Figure 26.2 

 
 
3. Capture a point of captured patch. (For more 

information see steps 2-3 of Step 18.) 

Figure 26.3 

 
 
4. To diminish the number of points in the captured 

section press right mouse button and choose the Knife 
part... command from the context menu. Then the Before or 
After Dialog Box will appear on your screen. 



ProGraph User's GUIDE 137 

 
5. Choose all needed parameters in the Before or After Dialog 

Box as shown below. 

Figure 26.4 

 
 
6. Click the OK control button. Then a new Geometry 

will appear on your screen. 

Note. APT format of opened file is violated. 

Figure 26.5 

 
 
7. To undo all changes:  

• Choose the Patches ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 26.6 

 
Then old Geometry will appear on your screen again. 
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Figure 26.7 

 
 
8. To copy a part of captured section to Clipboard 

press right mouse button and choose the Copy part 
command from the context menu. Then the section part 
from the first point up to the captured point will 
be copied to Clipboard. It may be placed at any 
position. 

 
9. To return to regime of section editing press right 

mouse button and choose the Exit command from context 
menu.  
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Figure 26.8 

 
 
10.To capture another section press right mouse button, 

choose the Next Section (Line) command from the context 
menu and capture necessary section. (For more 
information see steps 2-3 of Step 11.) 

Figure 26.9 

 
 
11.To place a copy of the Clipboard contents to the end 

of the captured section press right mouse button and 
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choose the Merge command from the context menu. Then 
a new Geometry will appear on your screen. 

Note. APT format of opened file is violated. 

Figure 26.10 
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Chapter 5. Special steps intended for experiment processing 
 
Step 27. How to convert WRL (STL) files into APT format 

 

Introduction. In many cases, it is convenient to work with files 
that contain structured grids. Nevertheless, the main constructor 
systems (for example, UniGraphics) create these files in non-
structured format. For more suitable work in these cases, a 
simple procedure that permits to obtain a structured grid on the 
model surface has been developed. 

ProGraph permits to convert non-structured grid into structured 
one. It may be performed with the use of the Convert to ~ APT... and 
the Convert to ~ SKL... commands from the Transformations menu. (For more 
information see Step 10.) These commands works safely for simple 
geometries but they lead to ambiguous results in complex cases. 
It is connected with complication of analysis in the cases of 
self-crossing the surfaces. 

In this Step an additional possibility is described. To its 
realization an algorithm of one-to-another grid reflection has 
been used. A normal vector is calculated at each node of the 
grid. Coordinates of point, where normal line (line directed to 
normal vector) intersects the non-structured grid surface, are 
determined. Point of intersection is named as New Target Point 
(NTP). As a result, we can receive the surface grid that consists 
of NTP. This surface grid is similar to template but contains all 
the nodes placed on the target surface (they are NTP). In fact, 
if template is a structured grid, then the result of projection 
is a structured grid too. The template may be created by any 
methods, but it is desirable to create it as close to target 
surface as possible. 

 
 
1. Open an existing file STEP_27.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 
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Figure 27.1 

 
 
2. Append an existing file STEP_27.WRL that is 

presented in subfolder SAMPLES of the current 
folder. Choose the Append wrl... command from the File 
menu. Then the standard Open Dialog Box will appear on 
your screen. 

Figure 27.2 

 
 
3. Choose an existing file STEP_27.WRL. Then the 

Geometry will appear on your screen. 
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Figure 27.3 

 
 
3. Rotate the Geometry on the screen to set convenient 

viewpoint.  

• Choose the Rotate... command from the View menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 27.4 

 

Then the cursor shape is changed to . 
 
4. Move the mouse and see how the Geometry is rotated.  
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Figure 27.5 

 
 
5. Capture the blue patch to the block. (For more 

information see steps 2-3 of Step 5.)  

Figure 27.6 

 
 
6. To create a new structured grid using non-structured 

surface grid (initial information): 

• Choose the Projection to wrl command from the 
Transformations menu. 
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or 

• Click the following icon from the right toolbar: 

Figure 27.7 

 
Then a new structured grid will remain on your 
screen. All the nodes of this grid belong to initial 
surface (defined by non-structured grid). 

Figure 27.7 
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Step 28. How to correct the Geometry grid using 
displacement of markers 
 

Introduction. During preparation of the experiment, the model 
surface is covered by markers. During the experiment the model is 
deformed. It results in shifting these markers. The same shifting 
takes place when the model surface is covered by a polymer to 
measure skin friction. Because of polymer liquidity, markers 
move. It permits to define local stresses and forces on the 
model.  

This Step explains how to deform the mathematical surface of 
model with taking into account measured shifting the markers. 
File SFT contains the coordinates of all the markers both before 
the experiment and during it (deformed model). It is assumed that 
initial positions of markers coincide with model surface given as 
grid file of APT or WRL formats (another formats of ProGraph are 
available).  

In general case, the procedure is following. The initial geometry 
and the file with markers are read. Then some geometry parts that 
are to be deformed are included into block. After the procedure, 
the geometry is deformed for the best correspondence with 
position of markers obtained during the experiment. For 
deformation, Micro-alignment algorithm is used. This algorithm 
has positive experience of implementation and it is described in 
OMS 3.1 Documentation. It is based on the least-squares method 
that is used locally. It permits to take into account local 
peculiarities of deformation. 

 
 
1. Open an existing file STEP_28.APT that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 
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Figure 28.1 

 
 
2. Append an existing file STEP_28.SFT that is 

presented in subfolder SAMPLES of the current 
folder. Choose the Append sft... command from the File 
menu. Then the standard Open Dialog Box will appear on 
your screen. 

Figure 28.2 

 
 
3. Choose an existing file STEP_28.SFT.  
 
4. To view markers choose the View features command from 

the Options menu. Then the View features Dialog Box will 
appear on your screen. 
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5. Choose all needed parameters in the View features Dialog 
Box as shown below. 

Figure 28.3 

 
 
6. Click the OK control button. Then pairs of markers 

will be shown on your screen. All the laboratory 
markers (X0, Y0, Z0) are painted with a yellow color 
and all the experimental markers (X0+dX, Y0+dY, 
Z0+dZ) are painted with a red color. 

Figure 28.4 

 
 
7. Rotate the Geometry on the screen to set convenient 

viewpoint. (For more information see steps 3-4 of 
Step 27.)  
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8. Capture the blue and grey patches into the block, 
for example. (For more information see steps 2-3 of 
Step 5.)  

Figure 28.5 

 
 
9. To transform grid and fit it to markers’ 

displacement choose the Projection to sft command from the 
Transformations menu. Then the result of transformation 
will appear on your screen. 

Figure 28.6 
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Step 29. How to open VAAC file  
 

Introduction. One of the most important problems is to compare 
experimental and numerical data. As a rule, formats of grid files 
used in CFD differ from formats used in experiment processing. 
So, it is very important, in the framework of the same 
application package, to have the opportunity to open a grid 
intended for CFD calculations and to convert it into inner 
ProGraph format.  

This Step helps you to work with a VAAC file that has GRD 
extension. This file contains a non-structured grid and it is 
described in documentation. To make the job convenient and 
pleasant for users there are two steps united together. Opened 
GRD file is investigated and sides that correspond to outer 
borders are selected. After it you can see 3D image of GRD file 
on your screen (the outer sides are represented only). As a rule, 
the experimental equipment (PST/TSP paint, pressure taps, etc) 
are placed at the solid surfaces of model and wind tunnel. For 
convenience of computation/experiment comparison, an additional 
command is created. To support this command an additional file 
with boundary conditions (of CBC/BC format) has to be read and 
analyzed. As result of this operation, you can see the image of 
VAAC file that is represented on your screen by solid surfaces 
only and only that outer borders of subregions, which correspond 
to solid surfaces, will remain on the base of this file analysis. 

 
 
1. Open an existing file STEP_29.GRD that is presented 

in subfolder SAMPLES of the current folder. (For 
more information see steps 1-2 of Step 2.) 
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Figure 29.1 

 
 
2. Rotate the Geometry on the screen to set convenient 

viewpoint. (For more information see steps 3-4 of 
Step 27.)  

Figure 29.2 

 
 
3. Append an existing file STEP_29.BC that is presented 

in subfolder SAMPLES of the current folder. Choose 
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the Append CBC... command from the File menu. Then the 
standard Open Dialog Box will appear on your screen. 

Figure 29.3 

 
 
4. Choose an existing file STEP_29.BC. Then the solid 

walls of surface grid will remain on your screen 
only. 

Figure 29.4 
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