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Chapter 1.  Processing a Project 
 

Files Necessary for Working with a Project 
 

Subfolder SAMPLES\STEP_1 of the current folder contains the 
STEP_1.XYZ file. This file was created in the ProImage 
application. For additional information concerning its 
creation, see Step 8 of ProImage How to... 

 
This subfolder also contains the following bitmaps: 
 

1) REFE_DARK.B16 – a dark reference bitmap;  

2) SENS_DARK.B16 – a dark sensitive bitmap; 

3) REFE_OFF.B16 – a wind-off reference bitmap;  

4) SENS_OFF.B16 – a wind-off sensitive bitmap; 

5) REFE_ON.B16 – a wind-on reference bitmap;  

6) SENS_ON.B16 – a wind-on sensitive bitmap. 
 
The subfolder contains the following files with 
information concerning markers: 
 

1) REFE_OFF.MPT – markers on the wind-off reference 
bitmap;  

2) SENS_OFF.MPT – markers on the wind-off sensitive 
bitmap; 

3) REFE_ON.MPT – markers on the wind-on reference 
bitmap;  

4) SENS_ON.MPT – markers on the wind-on sensitive 
bitmap; 

5) HST_315DD.MPT – markers on the image. This file is 
created manually by the user and used for 3D 
transformations; 

6) MARK_UP.APM – real 3D coordinates of markers on the 
model. 

 
This subfolder contains the following files with 
additional information: 
 

1) STEP_1.IMS – project file containing the information 
necessary for processing the PSP test data;  

2) UP.APT – file containing the geometry of the model; 
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3) COEFFNEW.CLB – file containing the coefficients of 
the calibration; 

4) PCO_CAMERA.CAM – file containing the camera 
parameters. 

 

 
Step 1.     Calculating the Cp Flowfield 

 
1. After running ProField, open an existing file 

STEP_1.IMS that is located in the subfolder 
SAMPLES\STEP_1 of the current folder. Choose the 
Open Project... command from the OMS Field menu. The 
standard Open Dialog will appear on your screen. 

Figure 1.1 

 
 
2. Choose the file STEP_1.IMS, and click the Open 

control button. The Open Dialog will be closed, and the 
OMS Property Sheet Dialog will appear on your screen. 

 
This project works with two fields transferred on the 
3D geometry: “sens” – ratio of the wind-on to wind-off 
sensitive images and “refe” – ratio of the wind-on to 
wind-off reference images. These fields were created 
using the “step_2pr.ims” and step_2re.ims projects 
included in the step_2 subdirectory of the 
Sample_ProImage directory. 
 
Significant angular parallax between the CCD cameras 
acquiring reference and sensitive images for bi-
luminophore paint application can create a problem in 
alignment between the sensitive and reference channels. 
In this case it is more desirable to align 
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independently the images in the sensitive and reference 
channels. The 2D-3D command in the ProImage Program 
allows the possibility of transferring all four source 
images on the mesh (after background subtraction, flat 
field and distortion correction).    

Figure 1.2 

 
 
3. Click the OK control button. The OMS Property Sheet Dialog 

will be closed, and the Geometry will appear on your 
screen. 



ProField User's GUIDE 6 

Figure 1.3 

 
 
4. To rotate the Geometry on your screen: 

• Choose the Rotate command from the View menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 1.4 

 

The cursor shape will be changed to . 
 
5. Press the left mouse button, and drag the mouse. The 

Geometry will be rotated around the axis that is 
directed from the point of view to the center of the 
model while moving the mouse. Release the mouse 
button at the final position of the Geometry. 
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Figure 1.5 

 
 
6. Choose the Cp Calculation... command from the OMS Field 

menu. The Cp calculation Options Dialog will appear on your 
screen. 

Figure 1.6 

 
 
7. Choose all of the needed parameters in the Cp 

calculation Options Dialog as shown above.  
 
 
8. Click the OK control button. The 3D Cp flowfield 

will appear on your screen. 
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9. To represent the Cp flowfield in a more desirable 

view, choose the Appearance... command from the Options 
menu. The Appearance Dialog will appear on your screen. 

Figure 1.7 

 
 
10. Choose all of the needed parameters in the Appearance 

Dialog  
 
11. Click the OK control button. The palette will 

appear in the right-hand portion of your screen. 
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Figure 1.8 

 
 
12. Click the Options control button at the bottom of 

the palette. The Spectrum Appearance Dialog will appear 
on your screen. 

 
13. Choose all of the needed parameters in the Spectrum 

Appearance Dialog.  
 
14. Click the OK control button. The 3D Cp flowfield 

will appear on your screen. It may be compared with 
the 3D Cp flowfield that was obtained in Step 2 of 
ProImage How To. 

 
15. Choose the Save Results command from the OMS Field menu 

to save the result of the Cp calculation.  
 
16. Choose the Close Project command from the OMS Field menu 

to close the project file.  
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Chapter 2.  Simple Operations with Files 
 

Step 2.       Editing the Geometry and Flowfield 
 
1. Open an existing file STEP_2.FLD that is located in 

subfolder SAMPLES\STEP_2 of the current folder: 

• Choose the Open... command from the File menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 2.1 

 
The standard Open Dialog will appear on your screen. 

Figure 2.2 

 
 
2. Choose the file STEP_2.P, and click the Open control 

button. The Open Dialog will be closed, and the 
Geometry will appear on your screen. 
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Figure 2.3 

 
 
3. To view separate blocks of Geometry, choose the 

Appearance... command from the Options menu. The Appearance 
Dialog will appear on your screen. 

Figure 2.4 

 
 
4. Choose all of the needed parameters in the Appearance 

Dialog as shown above.  
 
5. Click the OK control button. The blocks will be 

represented with different colors, and the front 
blocks will be displayed as a grid. 
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Figure 2.5 

 
 
6. To select a part of the Geometry: 

• Choose the Select... command from the Edit menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 2.6 

 
The Select Dialog will appear on your screen. 

Figure 2.7 

 
 
7. Choose all of the needed parameters in the Select Dialog 

as shown above.  
 
8. Click the OK control button.  
 
9. Click the necessary block. The nodes of this block 

will be represented as red markers. 
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Figure 2.8 

 
 

10. To magnify a portion of the screen on your screen: 

• Choose the Zoom Rectangle command from the View menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 2.9 

 

The cursor shape will be changed to . 
 
11. Press the left mouse button, and drag the mouse. The 

new picture fragment will be limited by the rectangle 
appearing on the screen. Releasing the mouse button 
rescales the picture. 

Figure 2.10 
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12. Choose the Destruct Mesh... command from the Edit menu. The 
Destruct Mesh Dialog will appear on your screen. 

Figure 2.11 

 
 

13. Choose all of the needed parameters in the Destruct Mesh 
Dialog as shown above.  

 
14. Click the OK control button. The grid of the selected 

block will become unstructured.  

Figure 2.12 

 
 

15. Choose the Undo command from the Edit menu. The grid 
of the selected block will return to the structured 
form. Figure 2.10 will appear on your screen. 

 
16. Choose the Redirect Normal command from the Edit menu. The 

normal of the selected block will become opposite.  
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Figure 2.13 

 
 

17. Choose the Undo command from the Edit menu. The normal 
of the selected block will return to the initial one. 
Figure 2.10 will appear on your screen. 

 
18. To show the Cp flowfield:  

• Choose the Field Variables... command from the Options 
menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 2.14 

 
The Field Variables Dialog will appear on your screen. 

Figure 2.15 

 
 

19. Choose all of the needed parameters in the Field Variables 
Dialog as shown above.  

 
20. Click the OK control button. The Cp flowfield will 

appear on your screen. (Figure 2.10 will appear on your 
screen.) 
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21. To view the Flowfield, choose the Appearance... command 
from the Options menu. The Appearance Dialog will appear on 
your screen again. 

Figure 2.16 

 
 

22. Choose all of the needed parameters in the Appearance 
Dialog as shown above.  

 
23. Click the OK control button.  

Figure 2.17 

 
 

24. Choose the Filter... command from the Edit menu. The Field 
Filtering Dialog will appear on your screen. 
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Figure 2.18 

 
 

25. Choose all of the needed parameters in the Field Filtering 
Dialog as shown above.  

 
26. Click the OK control button. The flowfield of the 

selected block will be filtered.  

Figure 2.19 

 
 

27. Choose the Close command from the File menu to close 
the opened file.  



ProField User's GUIDE 18 

Step 3. Representing the Flowfield Value as a 3D Object 
 
1. Open an existing file STEP_3.XYZ that is located in 

subfolder SAMPLES\STEP_3 of the current folder. (For 
additional information, see Steps 1-2 of Step 2.)  

 
2. To visualize the Geometry rotate it on your screen. 

(For more information, see Steps 4-5 of Step 1.) 

Figure 3.1 

 
 
3. Show the Cp flowfield. (For more information see 

Steps 18-20 of Step 2.) 

Figure 3.2 

 
 
4. Choose the Import 3D Field... command from the Import/Export 

menu. The standard Open Dialog will appear on your 
screen. 



ProField User's GUIDE 19 

Figure 3.3 

 
 
5. Choose the file STEP_3.XYZ, and click the Open 

control button. The Open Dialog will be closed, and the 
Import Dialog will appear on your screen. 

Figure 3.4 

 
 
6. Choose all of the needed parameters in the Import Dialog 

as shown above.  
 
7. Click the OK control button.  



ProField User's GUIDE 20 

Figure 3.5 
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Chapter 3.  Working with a Project File 
 

Step 4. Creating a Project File 
 
1. To create a new project file, choose the New OMS 

Project... command from the OMS Project menu. The OMS Property 
Sheet Dialog will appear on your screen. 

Figure 4.1 

 
 
2. Choose all of the needed parameters in the Test Features 

tab as shown above.  
 
3. Click the Write... control button. The standard Save As 

Dialog will appear on your screen. 
 
4. Create a subfolder SAMPLES\STEP_4 of the current 

folder, and enter it. 
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5. Type “STEP_4” in the File name text box, and click the 
Save control button. The Save As Dialog will be closed, 
and the project file with the name STEP_4.IMS will 
be created. Its name will appear in the This File 
information pane.  

 
6. Click the Refe Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 

Figure 4.2 

 
 
7. Choose all of the needed parameters in the Refe Files 

tab as shown above.  
 
8. Click the Sens Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 
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Figure 4.3 

 
 
9. Choose all of the needed parameters in the Sens Files 

tab as shown above.  
 

10. Click the T Files tab in the OMS Property Sheet Dialog. It 
will appear on your screen. 
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Figure 4.4 

 
 
11. This tab remains empty at this Step. It is used for 

processing TSP images. 
 
12. Click the Mesh Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 
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Figure 4.5 

 
 
13. Choose all of the needed parameters in the Mesh Files 

tab as shown above. The Field on Mesh text box is empty. 
In this version of the ProField application, a 
default filename is used. It is created by ProImage. 
For example, if ProImage runs project STEP_4.IMS, it 
creates the default name STEP_4.XYZ.  

 
14. Click the Resultant Files tab in the OMS Property Sheet Dialog. 

It will appear on your screen. 
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Figure 4.6 

 
 
15. The tab remains empty at this Step. In this case the 

appropriate filenames will be created as a default. 
In our case the image files will be named 
STEP_4_IREFE_ISENS.IMP, STEP_4_PRESSURE.IMP, 
STEP_4_P_PSTAT.IMP, and STEP_4_CP.IMP; the marker 
files will be named STEP_4_IREFE_ISENS.MPT, 
STEP_4_PRESSURE.MPT, STEP_4_P_PSTAT.MPT, and 
STEP_4_CP.MPT.  

Files for temperature are created for TSP only. 
 

16. Click the Test Features tab in the OMS Property Sheet Dialog. 
It will appear on your screen again. 

 
17. Click the Check control button. The presence of all 

of the chosen files in the project folder 
SAMPLES\STEP_4 will be verified.  
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18. Click the OK control button. The project file will 
be created, and all of the chosen parameters will be 
saved in it.  
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Chapter 4.  Additional Features 
 

Step 5. Drawing the Chart 
 
1. Open an existing file STEP_2.FLD that is located in 

subfolder SAMPLES\STEP_2 of the current folder. (For 
more information see Steps 1-2 of Step 2.) 

Figure 5.1 

 
 
2. View the Cp flowfield. (For more information see 

Steps 18-20 of Step 2.) The Cp flowfield will appear 
on your screen. 

Figure 5.2 

 
 

 
3. To draw the chart:  
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• Choose the Chart command from the Tools menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 5.3 

 
The step_2 (Cp) window will appear in the right lower 
corner of your screen. 

 
4. Press the left mouse button at the first point 

(cursor shape is changed to ), and move the mouse. 
Release the mouse button at the second point, and 
the function chart will appear in this window. 

Figure 5.4 
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Step 6. Creating a New Function 
 
1. Open an existing file STEP_2.FLD that is presented 

in subfolder SAMPLES\STEP_2 of the current folder. 
(For more information see steps 1-2 of Step 2.) 

Figure 6.1 

 
 
2. View the Cp flowfield. (For more information see 

Steps 18-20 of Step 2.) The Cp flowfield will appear 
on your screen. 

Figure 6.2 

 
3. Choose the Field Calculator... command from the Tools menu. 

The Field Calculator Dialog will appear on your screen. 
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Figure 6.3 

 
 
4. To create a new function, click the Create A control 

button. The New field name Dialog will appear on your 
screen. 

Figure 6.4 

 
 
5. Choose all of the needed parameters in the New field 

name Dialog as shown above.  
 
6. Click the OK control button. The warning message 

will appear on the screen.  
 
7. Click the OK control button, or press Enter. The 

function “new_Cp” will be created, and the Field 
Calculator Dialog will appear on your screen again. 
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Figure 6.5 

 
 
8. Choose all of the needed parameters in the Field 

Calculator Dialog as shown above.  
 
9. Click the A = B + C control button. The warning message 

will appear on the screen.  
 

10. Click the OK control button, or press Enter. The 
“new_Cp” will be equal to the sum of “Cp” and 10. 

 
11. Click the Close control button.  

 
12. Turn on the palette. (For more information see Steps 

9-11 of Step 1.) 



ProField User's GUIDE 33 

Figure 6.6 

 
 

13. View the “new_Cp” flowfield. (For more information 
see Steps 18-20 of Step 2.) The “new_Cp” flowfield 
will appear on your screen. The palette in the right 
portion of the application window will be changed, 
and the level of intensity on the bitmap will be 
increased on 10. 

Figure 6.7 

 
 

14. Click the Options control button at the bottom of the 
palette. The Spectrum Appearance Dialog will appear on your 
screen. 
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Figure 6.8 

 
 

15. Choose all of the needed parameters in the Spectrum 
Appearance Dialog as shown above.  

 
16. Click the OK control button. The 3D Cp flowfield 

will appear on your screen. It may be compared with 
the 3D Cp flowfield. 

Figure 6.9 
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Step 7. Self-Illumination Correction 
 

 Self-Illumination Correction Procedure requires source intensity 
distributions mapped on 3DMesh. 

ProField Program have special function – “Dress Image” located in 
“IMS Processing” Submenu (Fig. 7.1) to do it. 

Figure 7.1 

 

1. Use “Open OMS Project…” function to open standard ims project, sample 
“test_a00evs.ims” you can find in the Folder Sample_3 (Fig. 7.2) 

Figure 7.2 
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Figure 7.3 

 

Property Sheet (Fig. 7.3) will show you components of the loaded 
ims project. Don’t modify them – this sample has all necessary 
files, but in future you can do it for your cases. Original 
project doesn’t have resected data, so you can see only mesh 

You can use Appearance dialog from Options menu to choose 
appropriate mode of the mesh/field presentation 
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Figure 7.4 

 

2. Use “Resect Test Data..” function (Fig. 7.4) to start 
resection procedure dialog (Fig. 7.5) 

Figure 7.5 

 

3. In Resection Procedure Dialog (Fig. 7.5) select Wind Off 
Pressure and Wind On Pressure bitmaps for resection. Don’t 
use for this sample “Automarking” function – all markers are 
already available. Dark Subtraction is necessary, but Flat-
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Field Correction  and Distortion Correction  procedures are 
not applied for this case due to absence of the appropriate 
information. “Resect” Options Dialog give you possibility to 
choose resection procedure and marker enumeration methods 
(numeration of all markers on the bitmaps and on the 3D 
geometry in the same manner is not necessary now – program 
will try to do it now) 

Figure 7.6 

 

4. Choose appropriate function for presentation in “Fn” dialog 
(Fig. 7.6). Now you have “wind_on_sens” and “wind_of_sens” 
intensities mapped on the 3D mesh –“Field” and mesh itself – 
“Surface” (Fig. 7.7) 

Figure 7.7 
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Use appropriate knobs to adjust viewing direction, zoom and 
distance to the mesh. 

Figure 7.8 

 

5. Select “Self Illumination” function from “Tools” menu (Fig. 
7.8) and set parameters in the Self-Illumination Correction 
Dialog (Fig. 7.9 and 7.10) 

Figure 7.9 

 

For “wind_on_si” bimap and  

Figure 7.10 

 
for wind_off_si bitmap. 

6. By default procedure will add _si to the name of self 
illumination corrected field. Diffusion reflection ratio is the 
most delicate parameters here – should be taken from self-
illumination calibration or adjusted during trial and error 
iterations. Check visibility procedure time consuming – better to 
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select nodes which you are going to use in self-illumination 
calculation – use “Select” function from Edit menu. If nodes are 
not selected – all nodes will be used!! 

7. Self Illumination Procedure takes some time – duration depends 
on complexity of the number of selected nodes (Fig.7.11) Self 
Illumination Procedure should be repeated two times for this case 
– for wind-off-Sens and wind-on-Sens fields. 

 Figure 7.11 

 
 

Figure 7.12 

 
So now we have two self-illumination corrected fields 
“wind_off_sens_si” and  “wind_on_sens_si”, and normalizing 
procedure can be done using “Field Calculator” functions from 
Tools menu (Fig. 7.12) 
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Figure 7.13 

 

8. The first step here (Fig. 7.13) is creation of the new field 
“A” (Use “Create A” function), “ratio” was used as the name. 
Specify B and C components as “wind_off_sens_si” and 
“wind_on_sens_si” correspondingly,  and use “A=B/C” to calculate 
“ratio” field (Fig. 7.14) 

Figure 7.14 
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Figure 7.15 

   

Result presentation. Use “Options” dialog to select dynamic range 
and LUT. Plot shows (Fig. 7.15, right window) normalized 
intensity distribution for vertical section where cross cursor is 
placed.  

By default OMS3 saves resulted fields using XML format (files 
with extension “xyz” used for fields on the mesh). Don’t forget 
save results using “Save Results” function from 2D-3D Map menu, 
or you can use Import/Export menu to save results in the fld or 
TecPlot data formats (wrml is used only for mesh description). 
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Step 8. Calculation of aerodynamics loads 
 
Pressure field transferred on the mesh can be integrated to get 
load and moments acting on the mesh model surface. “ProField” 
program in “Tools” submenu has function “Distributed Loads” (Fig. 
8.1) to calculate integral loads and moments acting on the model 
mesh or selected blocks of this mesh. 
 
 

Figure 8.1 

 
 
Several assumption should be applied to calculate loads and 
moments Let’s assume that  is a part of surface, and  is 
normal vector of surface (Fig. 8.2) Outer side of surface is the 
side what 

S n
r

nr  is directed from. If  is an element of surface, 

then one may define a vector

dS
nS
rr
⋅= dSd . 

If pressure field  is determined on the surface (part 

of surface)  and parameters of ambient flow are 
r

, 

∞ , ∞

),,( zyxp
S ),,( ∞∞∞∞ = wvuV

p ρ , ∞ , ∞, then aerodynamic coefficients on this surface 
(part of surface) may be calculated.  

M T
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Figure 8.2 

 
1. In right orthogonal coordinate system , OZYX ,,, α  is angle of 

attack, β  is side slip angle and || ∞∞ = V
r

V ,(Fig. 8.3) then 
components of velocity vector are expressed as follows:  

.sin
,sincos
,coscos

β
αβ
αβ

∞∞

∞∞

∞∞

=
=
=

Vw
Vv
Vu

 

 
Figure 8.3 

 

2. Let’s calculate forces and moments with respect to a point 0R
r
. 

Two cases are possible: calculation of absolute force acting 
on the solid surface (cases a) and c)) and calculation of 
force due to overpressure that is defined with respect to the 
ambient pressure (cases b) and d)).  
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a) Force that is obtained by integration of pressure: 

).)(,)(,)((),,( 1111 zyx
S

FFFdzyxp =⋅−= ∫ SF
rr

 

b) Force that is obtained by integration of pressure 
difference : ∞− pp

).)(,)(,)(()),,(( 2222 zyx
S

FFFdpzyxp =⋅−−= ∫ ∞ SF
rr

 

c) Moment that is obtained by integration of pressure: 

),)(,)(,)((),,()( 11101 zyx
S

mmmzyxpd =⋅×−−= ∫ SRrM
rrrr

 

where rr  is radius-vector of center of surface element S
r

d . 
Pressure on this surface element is )(),,( rpzyxp

r
≡ . 

d) Moment that is obtained by integration of pressure 
difference : ∞− pp

).)(,)(,)(()())(( 22202 zyx
S

mmmdpp =×−⋅−−= ∫ ∞ SRrrM
rrrrr

 

Sign “-“ means that pressure force is directed inversely to 
the surface normal.  

3. Aerodynamic coefficients in system . (It is assumed 
that axis  coincides with construction line of model, it is 
directed from the leading part of model backwards. Axis  is 
directed upwards.)  

OZYX ,,,
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2
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m
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LSV
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SV
F

C
SV

FC

z
z

y
y

x
x

z
z

y
y

x
x
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∞∞∞∞∞∞

===

===

ρρρ

ρρρ

 

Coefficient of hinge moment with respect to some rotation axis 
is calculated with the use of overpressure, which is defined only 
with respect to the ambient pressure:  

( )
,

2

||
))((

32

2

s

s

LSV

dpp
M S

∞∞

∞∫ ⋅×−
−=

ρ
l
lSrr r

r
rrr

 

where  is usually area of aircraft wing, 1S
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1L  is wingspan (length of aircraft wing), 

2S  is area of surface behind the rotation axis, 

2L  is mean aerodynamic chord, 

3L  is mean aerodynamic chord of a surface part behind the 
rotation axis, 

srr  is perpendicular dropped from the center of surface element 

S
r

d  to the rotation axis 

l
r
 is rotation axis. Sign of  depends on direction of sM l

r
 

axis. 

 
4. Coordinates of vectors may be recalculated from the body 

system  to the flow system OZYX ,,, OZYX ,,, ′′′  using following 
formulas: 

,cossinsinsincos
,cossin

,sincossincoscos

ββαβα
αα

ββαβα

zyxz
yxy

zyxx

+−−=′
+−=′

++=′

 

where α  is angle of attack and β  is slip angle. 

To calculate the aerodynamic coefficients  and 

 in the flow coordinate system , it’s 
necessary to obtain the forces and moments in the flow system 

. These can be obtained by replacing  by 
 and , respectively. 

),,( zyx CCC
),,( zyx MMM OZYX ,,, ′′′

OZYX ,,, ′′′ ),,( zyx
),,( zyx FFF ),,( zyx mmm

5. Parameters of ambient flow are , , ∞M ∞p ∞ρ , α , β . Flow 
velocity may be expressed trough these parameters:  

∞

∞
∞∞ ⋅=

ρ
κ pMV  
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where 41.1=κ  is adiabata power. 

Components of vector ∞V
r
 are presented in section 1. 

Coefficients of forces and moments may be calculated for 

fields )(rrpC , )(r
r

p  and 
∞p

p )(rr
. 

1. If field  is activated, then, in the case of “body surface”: pC

).,),((
7.0

1

2
1)(1

2
1

2
1

))((

2
1
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2
1

12
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1
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Formula shows that field , values  and  are necessary 
to calculate the coefficients. 

pC ∞M 1S
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Formula shows that field , values,   and pC 1S ∞M 0R
r
 are 

necessary to calculate the coefficients. 

 

In the case of “closed-loop body”: 
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Formula shows that field  and value  are necessary to 
calculate the coefficients. 

pC 1S
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Formula shows that field , values  and pC 1S 0R
r
 are necessary to 

calculate the coefficients. 

 

2. If field  is activated, then, in the case of “body surface”:  p
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Formula shows that field , values ,  and  are 
necessary to calculate the coefficients. 

p ∞M ∞p 1S
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Formula shows that field p , values , ,  and ∞M ∞p 1S 0R
r
 are 

necessary to calculate the coefficients. 

 

In the case of “closed-loop body”: 
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Formula shows that field , values ,  and  are 
necessary to calculate the coefficients. 

p ∞M ∞p 1S
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Formula shows that field , values , ,  and p ∞M ∞p 1S 0R
r
 are 

necessary to calculate the coefficients. 

 

3. If field 
∞p
p
 is activated, then, in the case of “body 

surface”:  
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Formula shows that field 
∞p
p
, values  and  are necessary 

to calculate the coefficients. 

∞M 1S
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Formula shows that field 
∞p
p
, values ,  and ∞M 1S 0R

r
 are 

necessary to calculate the coefficients. 

 

In the case of “closed-loop body”: 
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Formulas show that field
∞p
p
, and values  and  are 

necessary to calculate the coefficients. 

∞M 1S
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Formula shows that field
∞p
p
, and values ,  and ∞M 1S 0R

r
 are 

necessary to calculate the coefficients. 
 
Designations in Distributed Loads dialog box (Fig. 8.4) 

In Attributes pane: Infinity pressure - , Alpha - ∞p α , Mach - 
, Beta - ∞M β . 

For correct calculation of aerodynamic coefficients it’s 
necessary to input values of parameters, for which the fields 
were obtained. If field of some parameter is inactive, then the 
value of this parameters isn’t required. The values of pressure 
field  and the value of pressure ∞  are to be expressed in the 
same units; geometrical parameters in dialog box and model 
geometry are to be expressed in the same units as well. 

p p

 

In Attributes pane: Specific Length - , Specific Square - 
, Average Chord - , X Focus, Y Focus, Z Focus – coordinates 

of vector 
r
. 

1L

1S 2L

0R

In Data for Hinge Moment calculation pane: X begin, Y begin, 
Z begin, X end, Y end, Z end – beginning of vector 

r
 and its 

end, Specific Square - , Specific Length - . 
l

2S 3L

In Hinge Moment pane: Ms - . sM

In Results for closed-loop body pane: the values of 
aerodynamic coefficients Сa - , Cn - , Cm - , Mx - , My 

- , Mz -  in model coordinate system . Сx - , Cy 

- , Cz -  - in flow coordinate system 

xC yC zC xM

yM zM ),,,( OZYX xC

yC zC ),,,( OZYX ′′′ . The values 
of coefficients are obtained with the use of integrating the 
overpressure.  
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In Results for body surface pane: the values of aerodynamic 
coefficients Сa - , Cn - , Cm - , Mx - , My - , Mz - 

 in model coordinate system . Сx - , Cy - , Cz - 

z  - in flow coordinate system 

xC yC zC xM yM

zM ),,,( OZYX xC yC
C ),,,( OZYX ′′′ . The values of 
coefficients are obtained with the use of integrating the 
pressure.  

 
Figure 8.4 

 
 

Calculations are initialized by knob “Calculate” (Fig. 8.4) 
and results of loads calculations can be written in text file 
using command “Write”. 
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Step 9. Pressure Port Correction 
 
PSP/TSP results can be corrected using pressure port 
data. Pressure port coordinates coupled with model mesh 
coordinates and corresponding pressure values should be 
provided as “mrk” format text file. Using normalized 
intensity data (Io/I) and pressure port it’s possible 
to accomplish “in-situ” calibration. 
Figure 9.1 

 
 

1. Load file with pressure field. Sample of such file can 
be taken from Step_9 folder.  

2. Choose active Field variable using “Fn” dialog. 
3.  Choose “Pressure Ports..” function in “Tools” submenu 

(Fig. 9.1) 
 
Figure 9.2 
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4. In “Pressure Port Parameters” dialog (Fig. 9.2) set 
order of approximation (maximum is 2) and maximum 
deviation between pressure port coordinates and 
corresponding point on the model mesh. This deviation 
is determined by accuracy of pressure coordinates 
measurements on the model and accuracy of the model 
mesh. Browse and select Markers file (sample is 
located in Step_9 folder). Select new field name which 
will be used to store corrected field values. 

5. “OK” button can initialize dialog “Active axes for the 
markers” to choose projection direction if only two 
pressure port coordinates are provided in mrk file. In 
this case third coordinate will be determined after 
projection of this point on mesh surface in the 
direction of the third axis.  

 
Figure 9.3 

 
 
6. “OK” button will initiate correction function which 

will calculate correction polynomials coefficient as 
least square approximation of pressure port data as 
function of active function values in the 
corresponding surface points. Spatial filtering 
procedure is recommended before to avoid possible 
noise influence in the source field. On the next step 
correction function is applied to all active function 
values to calculate new function. Pressure ports 
corresponding background function values or non-active 
blocks will be excluded from consideration. Corrected 
function can be visualized using “Fn” dialog.  

7. Correction procedure will be automatically documented 
in ASCII file presented in Table 1. In presented case 
zero order approximation was used – offset A0 between 
pressure taps and PSP was estimated and extracted from 
PSP pressure data. 
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Table 1 
 

ID Ac. X    Y      Z    Ptaps     Ppsp       Delta     Ppsp,corr Delta,corr 
---------------------------------------------------------------------------- 
 1  0 -0.40 0.01 -0.04 94724.834         0           0         0           0 
 2  0 -0.40 0.01 -0.10 93474.209         0           0         0           0 
 3  1 -0.31 0.01 -0.01 91009.825  95635.32  -4625.4951 90804.547  -205.27832 
 4  1 -0.31 0.03 -0.02 90997.376 95789.039  -4791.6626 90958.266  -39.110775 
 5  1 -0.31 0.05 -0.03 91032.329  95826.07  -4793.7417 90995.297  -37.031925 
 6  1 -0.31 0.06 -0.05  91051.96 95829.984  -4778.0249 90999.211  -52.748661 
 7  1 -0.31 0.06 -0.09 91136.228  95753.93  -4617.7012 90923.156  -213.07214 
 8  1 -0.31 0.06 -0.11 91287.529 95084.789  -3797.2598 90254.016  -1033.5135 
 9  0 -0.31 0.04 -0.13  92089.04         0           0         0           0 
10  0 -0.31 0.01 -0.14 91348.816         0           0         0           0 
11  1 -0.03 0.01 -0.00 92054.088 97029.594  -4975.5059  92198.82   144.73232 
12  1  0.02 0.01 -0.00 92127.344 97316.719  -5189.3745 92485.945   358.60092 
13  1  0.07 0.01 -0.00 92166.127 97336.063  -5169.9351 92505.289   339.16187 
14  1  0.15 0.01 -0.00 92093.828 97600.594  -5506.7651  92769.82   675.99188 
15  0  0.24 0.01 -0.00 91390.471         0           0         0           0 
16  1  0.07 0.06 -0.02 92187.673 96744.281  -4556.6079 91913.508  -274.16537 
17  1  0.07 0.08 -0.06 92112.023 96179.172  -4067.1492 91348.398  -763.62439 
18  1  0.15 0.08 -0.06 92001.899 96822.641  -4820.7417 91991.867  -10.031612 
19  1  0.24 0.08 -0.06 91604.974 97336.367  -5731.3936 92505.594   900.62018 
20  1  0.07 0.08 -0.12 91850.119 96268.945  -4418.8262 91438.172  -411.94733 
21  1  0.15 0.08 -0.12 92062.228 96854.078  -4791.8506 92023.305  -38.922913 
22  1  0.24 0.08 -0.12 91779.736 97270.797   -5491.061 92440.023   660.28784 
23  0  0.13 0.02 -0.17 92411.752         0           0         0           0 
24  0  0.18 0.02 -0.17 92071.325         0           0         0           0 
25  0  0.23 0.02 -0.17 91905.181         0           0         0           0 
---------------------------------------------------------------------------- 
Initial Dispersion = 4003.39, Final Dispersion = 397.975 
Approximation   Ppsp,corr = Ppsp + A0 
Where  A0 = -4830.770508,  D0 = 0.000000 
Maximum Absolute Deflection = 1033.51, at N = 8  
with Ppsp,corr = 90254, at X =-0.308539 & Y =0.0553664 & Z =-0.107188 
 
Second column identifies active pressure taps. Zero value means 
that this pressure tap was excluded from approximation mainly due 
to fact that field value for this point was background. 
The sample of used “Mrk” is presented in Table 2. This is xml 
formatted file having several records separated by keyword 
“<Function” plus field name in the beginning of record and 
keyword </Function> at the end. Record with the name “active” 
specifies pressure taps to be used in correction.  
 
 

Table 2 
<?xml version="1.0"?> 
<!--04/24/03 17:38:52--> 
<ObjectMarkers> 
 <NodesNumber>25</NodesNumber> 
 <Function id="x"> 
  -0.396113 -0.396113 -0.309753 -0.309753 -0.309753 -0.309753 -0.309753 -
0.309753 -0.309753 -0.309753 -0.0324104 0.0183896 0.0691896 0.15301 0.23683 
0.0691896 0.0691896 0.15301 0.23683 0.0691896 0.15301 0.23683 0.13269 0.18349 
0.23429 
 </Function> 
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 <Function id="y"> 
  0.00762  0.00762 0.0120142 0.0319024 0.04826 0.0586994 0.0613156 0.0605028 
  0.041275 0.0122682 0.0142748 0.0142748 0.0142748 0.0142748 0.0142748 
  0.054991 0.078994 0.078994 0.078994 0.0817118 0.0817118 0.0817118 0.01524 
  0.01524 0.01524 
 </Function> 
  <Function id="z"> 
 -0.0397256 -0.0953262 -0.0095758 -0.0168656 -0.0308102 -0.0504952 -0.0875284 
-0.109804 -0.128143 -0.137922 -0.0012954 -0.0012954 -0.0012954 -0.0012954 -
0.0012954 -0.0211836 -0.0596138 -0.0596138 -0.0596138 -0.124638 -0.124638 -
0.124638 -0.165659 -0.165659 -0.165659 
 </Function> 
  
<Function id="f" name="Pressure"> 
  94724.8344 93474.208 91009.8252 90997.3764 91032.3288 91051.9596 91136.2284 
  91287.5292 92089.0404 91348.8156 92054.088 92127.3444 92166.1272 92093.8284 
  91390.4712 92187.6732 92112.0228 92001.8988 91604.9736 91850.1192 92062.2276 
  91779.7356 92411.7516 92071.3248 91905.1812 
 </Function> 
 <Function id="active"> 
0 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 
 </Function> 
 <Function id="id"> 
 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 
 </Function> 
</ObjectMarkers> 
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